Rhino 6 installations fails

Unable to install Rhino 6 on my system. Attaching screenshot below-


I could not find any UninstallRelatedProducts.exe though. How to fix this?

Litty K.

Hello - can you send the log file indicated on the screen shot?


Log file shared via mail to tech.cn@mcneel.com


I have looked into your log file.

Please download and run the free Revo Uninstaller Portable (RevoUPort.exe). Use it to uninstall Rhino 6. There will be steps for you to select and clean up Rhino’s remaining files and registry keys. Then, you may be able to install Rhino again.

It fixed an unknown uninstall/install issue for me before. I hope it can be helpful in your case.

Hi Kelvin,

I downloaded and ran Revo Uninstaller Portable. However Rhino 6 does not appear under list of programs in it to uninstall it completely.

Please advise.


Can you try the fix tool from MS? Here

If it doesn’t help…

Do you see this dialog before the final error dialog?
If you do, please copy the whole path of the package cache for me, thanks.

Hi Kelvin,

Tried cleaning up using the tool from MS, I could see Rhino 6 in the list and went ahead and cleaned up. But still getting the same error screen.

And I do not get any dialog box with the package cache, it seems the error screens comes up before that.


No idea so far. The error code is 0x8007064c. If you google the error code, you can find many articles.

I see there’s another error log for the msi in your last install log. Can you send me this log file?