Update install errors

Every time I install a V7 update I get an error message saying the install failed. But when I click out of the message and cancel the installation it turns out that the upgrade has installed successfully anyway. I’ve attached the log file that was created.

Thanks,
Dennis
Rhino_7_20210805184535.txt (64.5 KB)

this is what the error log says-

Possible Solutions:

  1. Cause: The installer is unable to remove an older version of Rhino.

Solution: Run Microsoft’s Fix problems that block programs from being installed or removed, and select any components that have Rhino 6 in their name.

  1. Cause: The installer failed to install rhiexec.msi with error code 1603. This article explains how to resolve that error.

Solution: Read Install Error 1603 - Rhino 6 & 7 [McNeel Wiki].

Thanks Kyle. I tried all your suggested fixes and still have the problem. Not that it’s that big a deal since the update still installs. I’m just curious as to the cause. Screenshots, log file and sys info attached.

Dennis





sysinfo.txt (2.5 KB)
Rhino_7_20210807081555.txt (68.6 KB)

It’s throwing the same error-

is the rest of your machine working well?

When this happens, and won’t fix with the typical fixing tools, I typically recommend a clean windows reinstall-

People freak out when I say that, but it’s really not as big a deal as it used to be.

@brian or @John_Brock may have a less nuclear suggestion-

Thanks Kyle. Everything else is working fine. It’s really not an issue because the updates do install. It just keeps throwing up the same error notice. Is there stuff not being deleted I need to be concerned about? If not, I won’t poke the bear!

Dennis

ok, I’m always of the mind to not fix what’s not broken… obviously something is not running perfectly, but if rhino is doing what you need it to do, I’d stay the course. If it goes off the rails hit us back and we’ll dig deeper.

@dmoyes this is caused by a cached part of a previous installation no longer being present on your computer. We see this most frequently with products that clean up “unnecessary” things on your computer. The most famous is CCleaner (we strongly discourage people from using products like this).

Anyway, to fix it, you’ll need to run the Fix problems that block programs from being installed or removed, and tell it you’re having trouble uninstalling. Scan the list it provides for “Rhino Installer Engine” or “Rhiexec” and remove that entry.

Once that’s done, you should be able to install Rhino successfully.

Thanks Brian. I ran the fix it tool as instructed. I’ll have to wait for the next update to see if it worked.

Dennis