Rhino6 Update failure

Hi all,

Unfortunately, I am not able to install the recent Rhino6 update on my laptop (win10, x64, home edition premium). I updated my OS from win7 to win10 before and reversed it once. After the first OS update, Rhino6 updating was perfectly all right. But after the second OS update, the updating failed due to a ‘well-known’ error: rhino.msi :-2147023293 (rhino.msi cannot be found) .
Screenshot 2021-01-09 141029
Screenshot 2021-01-09 143847

I tried to load two other rhino.msi files, but the updating process still couldn’t continue. Btw, I can run the old version of Rhino6 with no problem, just can’t update it.

I tried every solution that I could find on the internet except uninstalling my Rhino6 (because of a lot of installed plug-ins and customized preference settings) like updating my windows and .NET 4.6 framework, start “Windows Installer” service and running MS trouble shooter. None of them can solve this issue.

I am not sure what is missing in my OS. Thus, I am asking for help with this frustrating issue… Is there any solution can work it out without reinstalling Rhino6? If I have to reinstall it, which folders should be made as a backup in order to keep the installed plug-ins (including Grasshopper) and customized preference settings?

Here is the updating error log.
Rhino_6_20210109152645.txt (285.6 KB)

Any help? Are the forum moderators there? Did I post it in a wrong section? -_-lll

Probably just got overlooked.

Things to try:

First, make sure your Windows 10 install is fully up to date.

In Windows>Programs, find Rhino 6 in the list, right click and choose “Change” then choose “Repair”. Then, once the repair is finished, perhaps try to install the latest SR - which I would download directly from here and then launch the install by double clicking on the .exe.

If that still doesn’t work -
Normally uninstalling Rhino does not uninstall settings etc. (unless you do a clean uninstall by manually wiping out a series of folders and registry entries). So simply uninstalling and reinstalling should preserve most if not all of your customizations which Rhino will pick up after the reinstall. However, if there is something in those custom settings/plugins that is actually causing the problem, then you will be back where you started.

It also may be that it’s your Windows installation that needs repairing.

1 Like

Thanks for the reply and help! This issue had been annoying me for such a long time. I had no luck with solving the problem by repairing Rhino 6 through Windows>Programs before. And I wasn’t able to uninstall Rhino 6 as well. I had to continue to use the old version, which was fine with me. Recently, I found that someone posed a similar issue in this forum. That solution solves my problem (the link: Rhino 6 update/install error rhino.msi: -2147023293 [SOLVED]).

The key point is using Microsoft’s troubleshooter to uninstall three things down below:

  1. Rhino6
  2. Rhino Engine Installer
  3. Rhino Language Pack

After that, the latest Rhino 6 can be installed successfully. As I can tell, most of the old plug-ins and settings are still there. Hope this will help some people that have the similar issues.

1 Like