Rhino 6 freezes upon start

I just installed Rhino 6.24 4 days ago and it has been working fine up until today. Now every time I open it the views don’t load and are blacked out. The startup prompt box opens and says loading plug-ins but I have never installed any plug ins. When I try to click on anything in Rhino the program freezes and does not do anything afterwards.

I have updated my Nvidia driver and windows drivers. There is no integrated graphics driver because it is disabled.

UPDATE: I just uninstalled 6.24 and installed 6.23 and the same issue happens.

Rhino 6 SR24 2020-3-19 (Rhino 6, 6.24.20079.23341, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Educational, build 2020-03-19
License details: Cloud Zoo. In use by: jacobsonblj ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: BRANDON

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 980 Ti (NVidia) Memory: 6GB, Driver date: 3-17-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 445.75

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 3-17-2020
Driver Version: 26.21.14.4575
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 6 GB

Rhino plugins
D:\Programs\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.24.20079.23341
D:\Programs\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
D:\Programs\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.24.20079.23341

Part of Rhino core functionality is implemented by way of plug-ins.

Something isn’t quite right. Perhaps do a clean driver install? (remove old drivers, including their files, then install latest).

I uninstalled the Nvidia driver and checked delete driver software and then shut off my computer. After I turned it on and redid the uninstall and powercycle, it worked for one second so it showed the regular rhino screen. But once I clicked on rhino, it crashed this time INSTEAD of freezing like it has been. I tried opening rhino again after and then it went back to just freezing like normal and not being responsive.

This is what it looks like when it freezes and goes unresponsive

This is the rolled back driver information, I don’t know why it is not detecting some details.

Rhino 6 SR24 2020-3-19 (Rhino 6, 6.24.20079.23341, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Educational, build 2020-03-19
License details: Cloud Zoo. In use by: jacobsonblj ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: BRANDON

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 980 Ti (NVidia) Memory: 6GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 432.00

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 7-24-2019
Driver Version: 26.21.14.3200
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 6 GB

Rhino plugins
D:\Programs\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.24.20079.23341
D:\Programs\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
D:\Programs\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.24.20079.23341

Hi -

I can’t tell from your pictures if you checked the “Delete the driver software for this device” option when you uninstalled. This step is very important. See the entire recipe here:


-wim

I got help by calling technical support and we uninstalled and deleted the driver and reinstalled an old driver from december and that made rhino work. The drivers we installed were the Nvidia geforce driver and the physX driver while not installing Geforce experience or the nvidia audio driver. Rhino was working for 3 days and it stopped working just now. I didn’t change any settings or delete or install any drivers or programs. I again tried to uninstall and delete this driver and reinstall a previous driver to this one and that didn’t work. So I did the same thing but tried to install the most recent driver and that didn’t work either. I also tried repairing rhino and also uninstalling and reinstalling and none of that worked.