Rhino 6 doesn't work anymore

Hi, every time I open a document is shows this:

I have reinstalled Rhino, updated it, updated both my graphic cards and shut down my computer several times and nothing works. Does anyone know what the problem might be? (I am using the 90 days free version.)
I have a windows 10 laptop core i7 64bit

Hi Alexandra - could you please run the Rhino SystemInfo command and copy-paste the result here?
Also, you write “doesn’t work anymore” - what has changed on your system since it was working correctly?
-wim

Rhino 6 SR24 2020-3-19 (Rhino 6, 6.24.20079.23341, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Evaluation, build 2020-03-19
License details: Stand-Alone
Expires on: 2020-05-11

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-DF6FCDT

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 11-19-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 1-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.23

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-31-2020
Driver Version: 26.21.14.4223
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

It used to open normally and show the objects in the document and the background used to be white, now it is black and the objects disappeared.

when I zoom this happens:

Hi - is this also happening with a new file from a factory-default template or is this specific to a file that you have been using?
-wim

It also happens when I open a new file without a template.
I need several files for school but they all show this problem.

-Alex

Hi Alex - it’s possible that a Windows update messed with the GPU drivers and simply reinstalling the drivers doesn’t solve that problem. I would try a “clean install” of the drivers of both GPUs following the recipe posted here:


Make sure to include step 4 of the uninstalling process as that is essential for this to work as intended!
-wim

Here are links to the current drivers for both display adapters. We think Windows updates may be responsible for messing with the OpenGL graphics, but we can’t identify which ones or how.
Updating the drivers almost always works.
The automatic “check for updates” driver tools have a very nearly 100% failure rate.
You have to manually go find the drivers yourself.
I’ve done that for you below.

Intel - From 25 March:

In your computer fusses about the Intel driver not being “Validated” for your computer, here’s how to fix that foolishness:

nVidia from 23 March:
https://www.nvidia.com/Download/driverResults.aspx/159091/en-us

Hi Wim
Hi John

My Rhino is still giving me the black displays and awkward figures.

I have done all of the above, including the all important step 4.

I am at my wit’s end, I need it for my university assignments.

What do you advise me to do?

Thank you in advance

-Alex