Rhino 6 Display Error

Hi everyone,
I am using Rhino Version 6 SR29 (6.29.20238.11501, 25/08/2020). After the most recent update, I noticed that my Rhino 6 displays fragmented/distorted geometries which was not the case before. I tried the same file with my Rhino 5 and worked fine. Here is the screen shot for comparison.

Similarly, if I create a brand new file in Rhino 6 and draw a box, the process for which I set box corners would show but the final geometry is not viewable. I doubled checked my display setting to ensure surfaces are checked. Here is the screen shot for reference.

Can anyone please lend a helping hand? Many thanks.

Hello - please try resetting your display modes to defaults in Options > View >Display modes
Also, please run SystemInfo in Rhino and post the results.
Lastly, see if disabling Rhino Resurf in Options> Plug-ins page and then closing and reopening Rhino helps - I doubt it, but worth a try.


Hi Pascal,
Thank you for getting back to me so quickly. Here is the system info per your request.

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Educational, build 2020-08-25
License details: Cloud Zoo. In use by: zwang2 ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: WANG

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 8-31-2015 (M-D-Y). OpenGL Ver: 4.4.0 - Build

Secondary graphics devices.
NVIDIA Quadro M5000M (NVidia) Memory: 8GB, Driver date: 6-5-2020 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.4
Shading Language: 4.40 - Build
Driver Date: 8-31-2015
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Users\Wang\Downloads\elefront422\elefront421\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\Wang\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.4.13.574\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\RhinoResurf\RhinoResurf_6.rhp “RhinoResurf”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Additionally, I tried reset display modes to default but it didn’t help with the issue.

Hello - You’ll need to make the NVidia card the primary display - in the Nvidia control panel you should have a setting to use ‘high performance’ rather than battery saving. In addition, please update the Intel driver to the latest from the Intel website.

If none of that helps, please try disabling the following plug-ins, in Options > PlugIns page, then closing and restarting Rhino:


Thank you Pascal. It issue is resolved after installing a couple of GPU updates.