Display bug after last update

Hi there,
i have a problem after I recently updated my Rhino 6 - Version 6 SR11
When I open my file, it shows colourful triangles everywhere. It’s uncomplicated rectangular shapes file - I use it for architectural 3D. No meshes. It looks like this in all types of viewport.
It never happened before.


NVIDIA System Information 01-04-2019 17-39-45.txt (3.4 KB)

I tried to repair the update, but I’m not a really IT guy… I don’t know what else to do.

Thanks for help,
Katka

Please run the SystemInfo command in Rhino and paste the results here. This looks like a GPU driver issue, but I want to make sure I know what Rhino sees for your system before making any recommendations.

Rhino 6 SR11 2018-12-14 (Rhino 6, 6.11.18348.17061, Git hash:master @ 600b621e607cf5226a968db60d7ac9230541b94d)
Licence type: Commercial, build 2018-12-14
License details: Cloud Zoo. In use by: katerina ()

Windows 8.1 (Physical RAM: 5.9Gb)
Machine name: VAIO

Intel® HD Graphics 4000 (OpenGL ver:4.0.0 - Build 10.18.10.3304)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build 10.18.10.3304
Driver Date: 9-9-2013
Driver Version: 10.18.10.3304
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2112 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18348.17061
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Your display adapter drivers are too old and buggy.
See if these drivers solve the problem:

Any luck?

It says my intel software is up to date…

Intel® Driver & Support Assistant

Detailed Report

Last scan: 1/4/2019 7:51 PM

Computer

Sony Corporation SVS1512X9EB
System Manufacturer Sony Corporation
System Model SVS1512X9EB
System Type Mobile
Motherboard Manufacturer Sony Corporation
Motherboard Product VAIO
BIOS Version R0081C8
SMBIOS Version 2.7
Secure Boot On

Operating System

Microsoft Windows 8.1 Pro (64bitový)
OS Build 6.3.9600
Locale Czech (Czech Republic)
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
.NET Framework Versions 2.0.50727.4927, 3.0.30729.4926, 3.5.30729.4926, 4.0.0.0, 4.7.03062
Default Internet Browser Internet Explorer 11.0.9600.19204
Installed Internet Browsers Google Chrome, Internet Explorer 11.0.9600.19204

Processor

Intel® Core™ i5-3210M CPU @ 2.50GHz
Manufacturer GenuineIntel
Description Intel64 Family 6 Model 58 Stepping 9
Architecture x64

of Cores 2

Current Clock Speed 2501 MHz
Current Voltage 2.0
Level 2 Cache 512 Kb
Level 3 Cache 3072 Kb
Processor Id BFEBFBFF000306A9
Revision 14857
Availability Running at full power

Chipset

Intel® 7 Series/C216 Chipset Family

Graphics

Intel® HD Graphics 4000
Adapter Compatibility Intel Corporation
Video Processor Intel® HD Graphics Family
Resolution 1920 x 1080
Bits Per Pixel 32
Number of Colors 4294967296
Refresh Rate - Current 59 Hz
Refresh Rate - Maximum 59 Hz
Refresh Rate - Minimum 40 Hz
Driver Provider Intel Corporation
Driver Version 10.18.10.3304
Driver Date 9/9/2013
Adapter DAC Type Internal
Adapter RAM 2.06 GB
Availability Running at full power
Status This device is working properly.
Location PCI bus 0, device 2, function 0
Device Id PCI\VEN_8086&DEV_0166&SUBSYS_909C104D&REV_09\3&11583659&0&10
NVIDIA GeForce GT 640M LE
Adapter Compatibility NVIDIA
Video Processor GeForce GT 640M LE
Driver Provider NVIDIA
Driver Version 22.21.13.8541
Driver Date 8/21/2017
Adapter DAC Type Integrated RAMDAC
Adapter RAM 2.00 GB
Availability Offline
Status This device is working properly.
Location PCI bus 1, device 0, function 0
Device Id PCI\VEN_10DE&DEV_0FD3&SUBSYS_909C104D&REV_A1\4&39F1A91E&0&0008

Audio

NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
Driver Provider NVIDIA
Driver Version 3.90.1.0
Driver Date 5/28/2017
Device Id ROOT\UNNAMED_DEVICE\0000
Zvukové zařízení High Definition Audio
Driver Provider Microsoft
Driver Version 6.2.9200.16384
Driver Date 7/25/2012
Device Id HDAUDIO\FUNC_01&VEN_8086&DEV_2806&SUBSYS_104D6500&REV_1000\4&ED7485A&0&0301
Zvukové zařízení High Definition Audio
Driver Provider Microsoft
Driver Version 6.2.9200.16384
Driver Date 7/25/2012
Device Id HDAUDIO\FUNC_01&VEN_10EC&DEV_0275&SUBSYS_104D6500&REV_1000\4&ED7485A&0&0001

Networking and I/O

Intel® Centrino® Advanced-N 6235
Manufacturer Intel Corporation
Availability Running at full power
Status This device is working properly.
Installed True
MAC Address C8:F7:33:1C:F7:D7
Service Name NETwNe64
Driver Provider Intel
Driver Version 15.10.3.2
Driver Date 8/22/2013
Device Id PCI\VEN_8086&DEV_088E&SUBSYS_40608086&REV_24\4&226FBB18&0&00E0
Revision 24
Řadič Realtek PCIe GBE Family Controller
Manufacturer Realtek
Availability Running at full power
Status This device is working properly.
Installed True
MAC Address 54:53:ED:AF:A6:C5
Service Name RTL8168
Driver Provider Microsoft
Driver Version 8.1.510.2013
Driver Date 10/5/2013
Device Id PCI\VEN_10EC&DEV_8168&SUBSYS_909B104D&REV_07\4&3859CFAF&0&00E2
Revision 07
Huawei EM680 w/Gobi Technology
Manufacturer Microsoft
Availability Running at full power
Status This device is working properly.
Installed True
Service Name wmbclass
Driver Provider Microsoft
Driver Version 6.3.9600.18879
Driver Date 10/12/2017
Device Id USB\VID_12D1&PID_1569&MI_06\7&C31A20A&0&0006

Memory

6 GB
Physical Memory - Total 6 GB
Physical Memory - Available 2.33 GB
Virtual Memory - Total 7.87 GB
Virtual Memory - Available 4.14 GB
Page File C:\pagefile.sys
Page File Space 1.94 GB

Storage

KINGSTON SUV400S37240G
Capacity 223.57 GB
Firmware Version 0C3J96R9
Serial Number 50026B726B052FAA
Partitions 6
Driver Provider Microsoft
Driver Version 6.3.9600.18758
Driver Date 6/21/2006
Device Id SCSI\DISK&VEN_&PROD_KINGSTON_SUV400S\4&33A9548E&0&000000
C:
File System NTFS
Compressed False
Capacity 220.80 GB
Free Space 15.61 GB

It’s not true.
That’s why I sent the direct link.

Ah, I missed the direct link - the Intel Assistant page opened on my first click…
Now I see it, I’ll try it.

I hope it works.
It may not as your old laptop maker may have tweaked the Intel drivers to extend battery life.
If that’s the case, you’re just out of luck I’m afraid.
It’s probably time to consider replacing it.
If it’s lasted this long, it’s done Yeoman’s duty and is ready to be retired.

Unfortunately it doesn’t work. It shows an error window, where it says it’s not approved for my computer and that I should ask Sony for appropriate driver :-/

I had my laptop upgraded last year with new SSD. I don’t want to put it away.
Is there any way to reset the Rhino update? It worked fine yesterday…

I made a fix last night that works around an Intel 4000 driver bug on old Macs which looks awful similar to what you are seeing. We should have a new internal build that includes this code change very soon. I’ll send you a link to this update if you want.

The older SR10 can be found at
http://files.na.mcneel.com/dujour/exe/20181104/rhino_en-us_6.10.18308.14011.exe
but that will obviously not contain the fixes that were made for SR11. If you want to roll back to SR10, you will need to uninstall the current Rhino first.

Sorry about the inconvenience. This specific GPU has been difficult to work with.

OK, please send me the link, I’ll try it. If it doesn’t help, I’ll go back to previous version.
Thanks.

Hi Katerina,
Here is a link to our latest internal build that has the Intel 4000 fix in it. Please let me know if this makes a difference.

http://files.mcneel.com/dujour/exe/20190104/rhino_en-us_6.13.19004.23511.exe

1 Like

hooray !!! it works! Thanks a lot!
image

1 Like

That’s great! Thanks for letting me know