Dimensions are buggy again, randomly disappear


#1

In the current version I have (6.10.18311.20531) dimensions randomly disappear when I change display mode or just move the view around. The dimension lines and arrowheads remain but the numbers disappear till I restart the program. Now that I think about I’ve had curves disappearing too. They don’t completely disappear I just can’t see them. If I draw a selection rectangle around them I can still select them.

I remember something like this back in beta before rhino 6 was released, just that back then everything randomly disappeared.

Is there any way to disable auto update in Rhino 6? Cause this is starting to get on my nerves. One version everything is fine (for me) and I have no reason to update, then it keeps bugging me with “new version available” till I let it update and and then something gets broken which makes the program a pain in the ass to use.


(Pascal Golay) #2

Hello - you can set your updating prefernces in Options > Updates and Statistics. But, meantime, there have been Windows updates as well that appear to have messed with at least some display things - not this specifically that I know of, but still,I’d make sure to get the most recent video driver from the manufacturer’s website.

-Pascal


#3

I updated the graphics drivers. It made no difference. (nvidia 416.94, released 3 days ago). I’ve got a GTX 1070 notebook version.
Curves still randomly disappear, dimension numbers still randomly disappear.

It’s something in the latest version that messes it up. I also updated the WIP version of Rhino today and it got the same issue after the update. I had not noticed it before in the WIP version either. If it’s related to the windows update or not I don’t know, but I haven’t seen any issues in any other programs.

Usually I’ve been messing with different display modes when it happens, not sure if it has anything to do with that. (Arctic / Artistic)


(Nathan 'jesterKing' Letwory) #4

So you change display mode settings, when you see dimensions disappear? And they work fine when you use the default settings for each display mode? If so please export and attach a display mode with your settings that shows the bug.


#5

I made two (to show it’s repeatable) short video clips https://www.youtube.com/watch?v=7_38L5LJ1ps&feature=youtu.be and https://www.youtube.com/watch?v=l-p-2vshgwg&feature=youtu.be.
I set them to private but hopefully clicking the links will still show them. If not I’ll have to set them to public instead.

I don’t normally create videos so, so just plain video capture using Geforce experience.

I noticed something interesting. It only occurs if I’ve modified the dimension style’s scale. (2nd video)
If I haven’t modified the dimension style, there is no issue. I also noticed if I zoom in real close the lines become visible again, but only while I was in technical display mode, when I switched to shaded zooming in didn’t bring back the curves.

I have modified the settings for some display modes, but technical has default settings (cause I don’t really use it)


(Nathan 'jesterKing' Letwory) #6

You can make them unlisted. That way one needs directly the link (like in your post), but at least can view. Right now they are not viewable.


#7

Ok thanks, I changed it.


(Nathan 'jesterKing' Letwory) #8

Could you please try disconnecting your 3dconnexion device, and load-protecting the 3dconnexion plug-in (Tools > Options > Plug-ins), then restart Rhino and see if you can still get the dimension texts to disappear?


#9

I don’t know exactly which plugin you wanted me to load. I only see one 3dconnexion related plugin in the list “3dconnexion 3d mouse”.

I tried unplugging the 3dconnexion device and do the same thing I did earlier without it. Same thing still happened. If I change the scale of a dimension’s font and then switch between certain display modes all lines and dimension text disappear.

Would be nice if someone else could try to replicate this bug, so it’s not something just on my end. But it happens both in retail rhino 6 and WIP. I might however have copied my Rhino 6 settings to WIP.


(Wim Dekeyser) #10

Thanks - I can repeat that here and will write it up.
YouTrack item RH-49524.


#11

A small update to this. I had the same thing happen when I saved a file. I didn’t change display mode, I just clicked on save and once it saved all lines and dimension text disappeared.

btw what’s up with rhino drawing straight horizontal lines as if they were at a small angle? (this might just be in a specific file I have, perhaps something wrong with the file)


(Nathan 'jesterKing' Letwory) #12

Are the lines far from world origin?


(S Brousse) #13

Hi everyone.

Same issue from France. Saving file makes text dimension disappear since last Rhino update (6.10.18311.20531, 07/11/2018).
I use Technical display mode and different model space scales all the time (teaching technical drawing to students).
Very annoying so thanks for fixing that asap.


#14

No but it’s just in this specific file I see these strange looking lines. If I try to draw a rectangle with the same dimensions in another file the sides won’t look tilted.

Copied the bit that is weird and saved it as a separate file. Not sure what is going on. The sides of the white rectangle are perfectly horizontal and vertical, but they don’t look like they are.

weird lines.3dm (643.1 KB)


(Nathan 'jesterKing' Letwory) #15

You probably pressed held Alt+Shift while panning in your top view - that rotates your view, making things look no longer straight.

Use _Plan in the top view to have everything look cool again.


(S Brousse) #16

Just saved my file too, and again most of dimension texts are gone :
Pen display mode, this time. Have to edit each text dimension to make it viewable again.


(Wim Dekeyser) #17

Like I wrote further above in this thread, that was a bug that was identified and fixed. When you install a new SR11 version tomorrow or on Wednesday, you shouldn’t be seeing this anymore.


(Hagop Bouchakjian) #18

Hello,

I seem to be having the same problem.
The update in options and through checking link both show I have the latest version.


(Vanessa Steeg) #19

Hi @Hagop92 - You have your “Update Frequency” set to “Service Release”. The current “official” Service Release is SR10. This bug fix was added to SR11. I believe if you set the “Update Frequency” to “Service Release Candidate” and restart Rhino, you should get prompted to install SR11 containing the bug fix.


(Hagop Bouchakjian) #20

Hi @Vanessa, Thanks for the quick response! downloading the update now.