Rhino 6 dimension bug?

Working with dimensions is super slow. copying, changing style, etc
Any fix?

Is this file-specific - or does that also happen with a new file from a factory-default template? If it is file-specific, please post the file. If not, paste the result of the SystemInfo command here.

Thanks!
its not file-specific, its happens to all my 4 pc with fresh R6 install.
What is the; result of the SystemInfo command?

The System Information entry under the Help menu.

OK! Here it is.
This is my home laptop. Same problem here. Feels like a GPU problem. At the office its GeForce 1070 and 1080.
Rhino 6 SR1 2018-2-6 (Rhino 6, 6.1.18037.13441, Git hash:master @ 5a33e6871b94d32ba552468218cef0ad8d3d1263)

Windows 10.0 SR0.0 or greater (Physical RAM: 12Gb)

Quadro 3000M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 369.09)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 8-1-2016
Driver Version: 21.21.13.6909
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - I don’t know if it is the real problem here but I see your video card driver is pretty old - I’d get the latest driver from the NVidia website and see if that makes a difference, then take it from there if there is still a lag.

-Pascal

Thanks Pascal!
Nvidia says Ive got the latest driver…but am I the ony one with this problem!? I got this lag on all 4 PCs all with different GPUs.

-Nico

Just installed R6 SR2, still lagging. I got this error message when installing. Anything to do with this?

-Nico

Hi @Nicolay_Nicolaysen,

In Rhino 5 that installation error would have been fatal, and would have required you to rebuild your computer. In Rhino 6, that error is not fatal, but there will be parts of Rhino or third-party plug-ins (I don’t recall the details right now) that will not work without the Visual C++ 2005 x64 runtimes installed.

This probably is not related to the lagging, however.

But here’s what I do know: failure to install Microsoft Visual C++ 2005 x64 runtimes is a problem that even Microsoft doesn’t know how to solve (and the runtimes are their product). The solution I’ve always gotten from Microsoft for this problem is to format your hard drive and do a clean reinstall of Windows. Who knows, maybe that would have a positive impact on the lagging Rhino? I’ll let you decide what to do next.

Thanks Brian!

The “funny” thing is that I formatted all PCs at the office and home prior to R6 install to get it perfect. Oh! the irony. I spoke with Microsoft support today and they told me you Rhino guys would give me the correct .msi file. Can you believe it?
Im getting a little deserate here as I run a small architectural office and production is stalling.

  • Nico

I`ve now managed to install R6 whitout C++ 2005 error 1935. I formatted the PC, installed R5 and then R6. But the Dimension lag is still there as Brian suggested. Is there any answer to this? Am I the only one experiencing this? Shall I make a video showing the lag?

I’m sorry but I have the same problem, in a small file with about 10 dimensions any operations with them are ultra-slow. It takes ages to be able to edit text or move their CPs even if I have single top-view wireframe viewport.

On i7 8700K and RTX 2070.

Cheers
Jonas

Hi @Jonish,

Could you copy the text from Help -> System Information... here? Also, could you attach the problematic file?

Thanks,
-David

Hi David,
I must have gotten carried away last night. Trying to reproduce it now, I hight have had an arctic viewport opened. (I really got used to it sooo bad.) I will definitely follow up on our conversation if the lag mysteriously pops up again.

Cheers and sorry for a (probably) false alarm
Jonas

I am having this problem also. systeminfo below. It takes about 5 seconds for the dimension properties tab to populate. Every time a dimension is selected rhino is frozen for about 3-5 seconds. Any insight would be much appreciated.

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Cloud Zoo. In use by: ------------------ ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: --------

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GT 1030 (NVidia) Memory: 2GB, Driver date: 3-16-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 391.25

Secondary graphics devices.
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-28-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-16-2018
Driver Version: 23.21.13.9125
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.13.19058.371
C:\Program Files\Orca3D V2\Orca3D.rhp “Orca3D” 2.0.6.0
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2018 for R6\RhinoArt1FileExporter For Rhino6.0.rhp “RhinoArt1FileExporter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - can you please try disabling Orca and RhinoArt1FileExporter For Rhino6.0
in Options > Plug-ins page, then restart Rhino and see of the problem persists?

(Your video driver is getting oldish - I do not think that is directly related to the lag but you might try opening the Notifications panel (Panels menu) and double click on the video driver notification and follow along to update)

-Pascal

Thank you very much. Disabling Orca and Exporter helped quite a bit. Probably about 70% fixed and files load much faster. Not sure why I never though to try that before and I certainly don’t need those plugins loaded all the time. There is a driver update available. I’ll give that a try as well. THANK YOU!