Rhino 6 different result open file directly or via open file

Goodday all,

A customer of ours has a specific problem and maybe someone knows what is happening. When they open the file by double click they get a different result than opening it with Rhino => File => Open…

  • Changing display view doesn’t change anything
  • The Picture frames do contain the images
  • Opening the same exact file via Desktop or File => Open different results
  • This happens with every file

Hereby some screenshots:

Opening as it should via Rhino => File => Open:

Hereby SystemInfo of the system:

Rhino 6 SR31 2020-11-10 (Rhino 6, 6.31.20315.17001, Git hash:master @ ff08c426b1ef7d3a1c50a01e5e87220a68a9f815)
License type: Commercial, build 2020-11-10
License details: Cloud Zoo. In use by: steven ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: W15-LHEERLEN

Non-hybrid graphics.
Primary display and OpenGL: Radeon RX 550 (AMD) Memory: 4GB, Driver date: 5-7-2020 (M-D-Y). OpenGL Ver: 4.6.13596 Compatibility Profile Context 20.10.10.02 27.20.1010.2001

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 5-7-2020
Driver Version: 27.20.1010.2001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\steling\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.31.20315.17001
C:\LutraCAD\LutraLast_V6.rhp “LutraCAD” 2.4.3.0
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

All help is appreciated.

Thanks,

Jordy

Hi Jordy - does it make any difference if the user disables LutraCAD in options > Plug-ins page, and closes Rhino and tries the same test?

-Pascal

Hi Pascal,

Thank you for your reply.

Sadly it didn’t work.

What is weird is if I add a new picture frame and if I select something or deselect the other pictureframes will change, but when I check the location of the image of the existing ones it shows the correct image.

Any other ideas?

Hi Jordy - if you can send us the file, that would be best I suppose - tech@mcneel.com, with a link back to this topic in your comments, please. If you can reproduce the problem in a simplified file without geometry that would be even better.
And, just in case: what does the camera and target locations look like in that view in Properties (no selection)?

-Pascal

Hi Pascal,

Sorry for the late reply. I have asked for a screenshot.

This does not happen only to 1 file, but all files that are being opened.

They have latest video drivers and latest Rhino 6 version.

Do you have any idea what could cause this problem?

Thanks,

Jordy

Hi Jordy - does RefreshAllTextures sort out the display when it opens ‘wrong’?

-Pascal

Hi Pascal,

Hereby the screenshot:

image

Hi @jordy1989,

Could they have more than one Rhino installation on their machine, with the file association pointing to one and the shortcut pointing to another?

Run Rhino each way and, while running, open Task Manager, highlight the running Rhino, right click and select Properties. Carefully compare the General and Details tabs for the two runs to see if they use the same instance of Rhino.

Regards
Jeremy

Hi Jeremy, Pascal,

Thank you for your responses.

RefreshAllTextures seams to fix the problems. So they know they have to call this function when this happens.