Rhino 6 crashing on startup so much I am not using it really

Rhino 6, regardless of recent backups, just crashes profusely on startup.

I cannot get a run out of it at all, often, so I am very very very happy there is Rhino 5 here. I installed 6 from scratch but it still complains some plugins from 5 are there, which is weird as I removed 5 beforehand in this multi-day odyssey waste trying to get this to “run”. It won’t. It tells me there are old plugins and then it freezes entirely. That’s it. There are no old plugins, only Boltgen the latest version, which runs fine the few times Rhino 6 decided to actually start up, and even if there are incompatible plugins, why cannot Rhino just not load those and not freeze maybe?

How would we rationally go about this? (Windows 10 latest updates etc, all other stuff runs here).

Start V6 using the Rhino V6 in Safe Mode shortcut.
In Options > Plug-ins, change the list filter to plug-ins that do not ship with Rhino.
Disable all of them.
Close and restart Rhino normally (not safe mode).
Rhino should start.

Systematically enable the plug-ins one at a time, load them, and identify the offending plug-in.

Any luck?

So I get that warning about “old” plugins for a reason I do not understand. The only plugin that I had actually installed myself was Boltgen.

That plugin however runs perfectly well also inside safe mode, creates threads etc. without issues. It also ran without flaws when the “normal” Rhino 6 had started eventually (which it did, maybe 1 / 20 start attempts, but now not so much any more).

So Boltgen does not stand out as offending plugin. The other plugin functionalities came pre-installed.

When I run Rhino 6 Safe Mode, and manually load all plug-ins (Options > Plugins > …), as expected, no crash occurs. Boltgen as my only “extra” plug-in works fine as well.

That troubleshooting procedure cannot logically function as that, otherwise this would not be a problem. How is a plug-in “offending” if it does not cause any actual issue when manually loading it from Safe Mode? In what way is the code used in Rhino 6 (normal version) startup different from Safe Mode plugin loading? Somewhere the same code should be tested again, and an error produced to highlight any faulty plugin.

It is entirely unclear why the software crashes, but from here it is certainly not a plug-in I could identify with that method.

Update: it may actually be a plug-in that came pre-installed with Rhino 6? I noticed that starting Rhino 6, the little log window on top said “Blocking plugin 3D connexion 3D Mouse” just before the program froze. I found this as pre-installed plugin in both Rhino 5 and 6. I removed them from the plugin folder but the program still crashes, although, without that error, now.

If you’re getting random crashes in non-safe mode, it may be a video card/driver issue then… Can you run SystemInfo inside of Rhino and post the results here?

Rhino 6 SR4 2018-4-3 (Rhino 6, 6.4.18093.10341, Git hash:master @ bfdc5b98e028aea659372f9a67d36edb21f28713)
Licence type: Educational, build 2018-04-03
License details: Cloud Zoo. In use by: Wolf Schweitzer ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: Y52D36SHWI2

Unknown (OpenGL ver:(null))

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 6-27-2017
Driver Version:
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: 1375720256 x 32761
Total Video Memory: 8 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”

Can you manage to run SystemInfo in normal (not safe) mode before Rhino crashes? Unfortunately the info above in safe mode doesn’t tell us anything about the video card/driver…

Also, just as a second test, while in safe mode, if you uncheck the following in Options>Advanced:

then restart Rhino in normal mode - do the crashes stop?


Thanks. Rhino 6 does not start, at all. It always freezes after the dialog of old plugins having to be checked comes up. I had uninstalled and reinstalled it and updated it etc but to no avail. Switching off Open GL hardware driver did not change anything at all.

The few times Rhino 6 ran it did not randomly crash. However getting it to run always was a luck / no luck thing. Now it does not seem to start at all ever any more. So I cannot test anything there because it quite simply does not run. At all.

Did you try a clean uninstall (i.e. get rid of everything)? First, uninstall Rhino 6 via Windows control panel, then do the following:

Open regedit, and delete the following keys entirely:


Then also delete the following folders on your hard drive:

(type %appdata% at the start button to get to “Roaming”)
“C:\Program Files\Rhino 6 (or 6.0 or…)”
“C:\Program Files\Rhino WIP or Beta” (if they exist…)

Then restart your computer and try re-installing…

Thanks. Is it necessary to also totally remove Rhino 5 or are these directories and Regedit entries of no concern at all for Rhino 6 stability?

No, not at all.

The installs should be completely separate.


Would you allow me to remote control your machine to see what the problem is? If so, please DM me.

  • Andy

Thanks for the offer … RC not possible here.

I performed a clean uninstall as indicated, and re-installed Rhino 6. Upon first start and ever since just as before, the Rhino 6 (normal) version freezes / crashes upon start. As opposed to before it now does NOT show the “blocking 3D …” error as indicated above.

To be honest I had already repeatedly installed it prior to that, trying to “coerce” it into submission, but no success. Again, as expected, nothing.

If you have an idea, great, otherwise not so stable here. At least one can re-convert Rhino 6 files to Rhino 5 within safe mode!

@wolf.schweitzer what display adapter do you have to run your monitor(s) ?

Find out through right-clicking on the Windows start menu, select Device Manager, then open the Display Adapters section and take a screenshot of that part (Use Snipping Tool, which comes with Windows 10). Please post here.

On my machine it looks like this:


I’m out of them for the moment, this is now outside my sphere of knowledge… If it’s not video-related, then I guess it’s something particular having to do with your system… I’m not a computer guy really.

@wolf.schweitzer when Rhino crashes, does it ask you to submit the crash to McNeel? If so, do you? And if you do, will you please include your email address in the crashes so that we can find them?

When I first started using V6, BoltGen was one of the first plugins I installed. I got odd crashes and some indication there were some commands in BoltGen that weren’t playing well with V6. I just kept an instance of v5 running and would create my bolts there and copy them into my V6 instance. A couple of weeks later after a v6 update and maybe a second attempt to load a fresh download of BoltGen everything seems to be working fine now. Go to the BoltGen page and get the latest version for v6 and see it that helps.

I just tried BoltGen again as I remember some odd things happening with the command CopyBolt to Surface when I first had my crashes. I was not even aware of the extra commands for BoltGen until my last download and install but there are some odd things going on in the background with that command. Here is what I see in the Command History. What the heck is a 'deprecation warning'?

Command: BoltGenHelp
Command: CopyBoltToSurface
:1: DeprecationWarning: LayerTable.FindByFullPath has been obsoleted. ignoreDeletedLayers is no longer supported for research by name. Use the overload with notFoundReturnValue (-1 was the previous default).
:1: DeprecationWarning: LayerTable.Find has been obsoleted. ignoreDeletedLayers is no longer supported for research by name. Use the overload with notFoundReturnValue (-1 was the previous default).
:1: DeprecationWarning: Layer.CommitChanges has been obsoleted. No longer needed. Layer changes in the document are now immediate
Creating meshes… Press Esc to cancel

The crash is never accompanied with a message asking to submit anything.

Device Mgr > Display Adapter > NVIDIA GeForce GTX 1070 (only one entry there)