Rhino 6:Clipping plane fills print with wrong color. any workaround?

Hi,

trying to print out plans, an I am hitting a show stopper right now:

I just can’t get the clipping plane fills to print with the color shown in the viewport.
(I tried all fill variations, like plane material, solid etc.)

they only print in original resolution when using viewcaptureto file, eg. tuning scale to 2 makes them print with default grey… I need black fills… but I just can’t get them out there. export via printing has the same flaw like viewcapturetofile. What works is screencapture to file… but I can only drag the viewport to the width of my to screens, and I need higher resolution…

testing a simple file, the error shows as well. do you have any suggestion how to work around it?

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 7 SP1 (Physical RAM: 48Gb)

GeForce GTX TITAN X/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 397.64)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Nothing…?

Having the same issue here.

Please share a file with a simple scene that shows what is going on. In case that you are not using factory-default display modes, please also send a copy of the one that you are using. Finally, tell us which settings you are using in the print panel.

I’ll provide a file and some screengrabs tonight, but until then… I’m using the default Shaded display mode which defaults Clipping Plane Fill with the Viewport option. If I change that option, cycling through them all, on my screen they change accordingly, but when I go to print, the preview displays the fill as how the default ‘Viewport’ option displays it. As if I never changed any settings.

Oh my god, I figured it out…

You have to use ‘Viewport’ as the fill option under Clipping Planes (in Display Mode properties), but for some reason under Shading settings (also in Display Mode properties) choose single color for all BACKFACES. This is where you get to choose a single custom color to fill all clipping planes. Printing works also!

Thank the heavens.

I’m still having problems figuring this out and hope you can help me through this.

I start with a factory-default Shaded display mode.
The only 2 things that I change to this display mode are:

  • [Shaded] > Clipping plane objects > Color usage -> Solid color
  • [Shaded] > Clipping plane objects > Fill color -> some color

In the viewport, my object now looks like this:
image

The print preview looks like this:

And the final PDF looks like this:

Are you saying that this procedure doesn’t work on your end?

Hi Wim, sorry for the delayed response.

But yes, that procedure does not work for me. I’ll put together some screengrabs to prove I’m taking the same steps, but it seems when I go to print, the preview doesn’t display the solid color and instead sees right through to the backfaces. It seems the print preview part of the process is ignoring the fact that I’m changing the clipping plane display option.

I’m happy with the workaround, but I figured your procedure was the correct way to achieve what I’m after. Thanks!

I have a similar problem.

The fill is showing but I can not control the color of the fill.

@devingrayart, @johann,
Please provide as much information as you can. I will need the model, your modified display mode (ini file), screenshot of the print preview and the pdf that is printed.
Thanks!

Same problem for me, will be sharing the files as soon as i get back home.

@wim

I am not seeing the clip fill in viewport either, so nowhere.

clip green fill.3dm (65.7 KB)
clip green fill.pdf (74.9 KB)

Shaded_clip green fill.ini (12.5 KB)

@wim

I found a workaround, activate “Color Backface” with the desired color.

Maybe that is a hint to what the problem is??

@johann, that’s the same workaround that @devingrayart used to “solve” the issue.
The thing is - @devingrayart was only having problems in the print preview (and print), not in viewports in the model space. The printing problem was a known issue (RH-48472) and is fixed in SR10 that was released yesterday.

The problem with the fill color in regular viewports is not something I can reproduce on my machine. I get this when I open your file with your Shaded display mode:
image

It’s definitely worth a try to install SR10 and check if the fixes also solved this.
Else, please run the Rhino SystemInfo command and post the result here.

I’m on SR 11, and I can’t get Clipped fills to display or print.

If you are able to reproduce this in SR14 or the current SRC15, please provide a simple file that shows that behavior.
-w

Dimensions don’t work properly in either of them, so I won’t’ be using them f.or the time being.

Can you please check the behavior in the technical display.

here I do not seem to have ANY control over the color the clipping fill displays.

no matter if print display is on , layout space or model space…

thnx,
daniel

This is (for me) a serious problem I haven’t been able to solve in Rhino.

I can get them to display correctly in shaded mode, and I can print them successfully with the desired colour.

But in Technical display, I can’t change the colour whatsoever I try…