Clipping plane, Colour options?


#1

Hello I am trying to change the colour of the fill that is generated when i create a clipping plane through a solid object, it defaults to a black colour and i believe i should be able to adjust it in the Display modes setting.
But when I change it to solid colour it doesn’t appear to up date in the main view, and ideally the layout view also.
Cheers.


(John Brock) #2

It seems to be working here as expected for me.
Are you sure your Top viewport is in a Shaded display mode?


#3

Hello John,

Thank you for taking the time to have a look at this, Im Confident the top view port is shaded as it doesn’t show any fill at all if in wire frame, and it’s displaying a black Square in my screen grab when shaded.

I guess I’m missing some setting some where, as I cannot change that fill colour to any thing else but the default black but i am able to toggle the fill on and off (see screen grab below) as i have the back surfaces set to a burnt orange which is revelled when i toggle the fill option off.

any advice much appreciated.

regards

Quinn.


(John Brock) #4

Interesting…
I was able to duplicate your display but in the process found an easy work-around.

In the Lighting scheme settings above the clipping plane display options, select Use advanced GPU lighting.

I’ll get this on the defect list as the problem is in 5.2 and in the WIP.

Thanks for reporting it.


#5

Hi John,

Thats a great work around and giving me the result I was after thank you very much.
Ill keep flagging any issues I run into, but you guy’s are doing a great job, Absolutely loving Rhino.

Cheers

Quinn.


#6

HI @John_Brock

This bug is still happening in current WIP 5.4

Default Lighting


Advanced GPU Lighting

No Lighting


(John Brock) #7

I couldn’t find the old bug report so I added it again:
https://mcneel.myjetbrains.com/youtrack/issue/MR-3094

At least it’s easy to work-around.
My guess is this will be fixed when Mac Rhino WIP jumps to the V6 code base.