Clipping plane fill errors

Hi McNeel,

There have been a few posts about the bugginess of Display Mode’s Clipping Plane Fill ability (topic 1222, 10009, 2065).

Do you have any solutions or workarounds yet?

What I usually get is clipping planes that do not fill a solid object at all. This happens more often than anything.

Next, Rhino will display a partial fill on a clipped object, stopping the clipped fill in some random middle of the object.

Lastly, and only in a few very simple tests, will the fill fully work.

  1. While trying to make a file to send to you, I had a situation where 3 clipping planes were on. This resulted in a partial fill of only one of the clipping planes. The other two were open/ empty.

  2. When I unhid all the objects (as I had hidden some to focus on this issue), the clipping plane fill properly filled the solid objects on all three clipping planes. So I thought this might have to do with hidden objects.

  3. So I undid the show command, grouped the objects that were partially filled, then unhid everything. Typed Invert to flip the selection, deleted everything else (so there are no hidden objects and nothing else in the file). Rhino went back to the partially clipped fill as in step 1. Really odd.

Some of this seems to be issues with hidden objects or layers that are off (perhaps groups), but I cannot make sense of it.

Thank you,

Hi FlynnAD- in the last scenario - does any of the other clipping planes correspond to the location partial solid fill above?


Hi Pascal,

No. All the other clipping planes that are shown in image #3 are parallel to or perpendicular to the clipped-fill-object-edge, but those clipping planes are not in the location (or extension) where the partial fill was clipped.


I’ve encountered similar problems today with intermittent fill of clipped objects. At first there seemed to be no pattern, but I did some experimentation and think I may have uncovered a workaround (and perhaps a clue that could help track down the bug): it seems that having visible geometry at/near the origin remedies any clipping fill errors.

This seems to work regardless of object type (I tested a point, curve, surface, extrusion, and brep). And it seems to work regardless of if the origin object is being clipped or not. (In this example, I can flip the clipping plane; the point is no longer visible but the clipping fill still works).

I tested a bit further in a simple model and found some weird behavior relative to clipping plane orientation:

Any thoughts on addressing this bug? Something that’s coming to 5? Or something that will get addressed in 6?
FYI: I’m using Version 5 SR14 64-bit (5.14.522.8390, 5/22/2017)

I think this has been fixed in V6.
Please give it a go and let us know if it’s better.

Clipped plane fills aren’t reliable for me. (Three images below from Rhino 6 SR6):

Model Space (Sometimes the fill colour shows, sometimes it doesn’t. The view with the missing fill lost it when it was converted to a Front view and back again to perspective.)

Layout Space (This is what they should always look like, but those green fills come and go in the display as I work on the project. When they go, the clipped planes become the object colour.)

The Print (They never print.)

Hping for news on this. Sectional perspectives are a great tool but unreliability of fill is a significant handicap.

I can reproduce the issue with the PDF export not printing the clipping color - RH-48472.

I haven’t been able to reproduce the other issues that you mention. Can you post a simple file that shows this behavior?

I can’t get any fill other than the default to show up. ever

Copy of Shaded.ini (12.5 KB)
fill bug.3dm (432.9 KB)

here are my files if it helps!

1 Like

As you can see in the print in my project a post above, the thick lines at the clipped edges don’t print either. I’ll upload this file via the upload link.

I tried moosejuice’s point-at-origin solution but it doesn’t fix the absence of fill display in the perspective view.

Sectional perspectives are a powerful architectural illustration tool.

Hello @alr - I get the green clipped plane here - can you please run the SystemInfo command in Rhino and paste the results here?



Rhino 6 SR9 2018-9-10 (Rhino 6, 6.9.18253.21101, Git hash:master @ f7cbad0c040a5ec317eace6ef2e7e57756bfc855)
Licence type: Commercial, build 2018-09-10
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: PC-BXL-13

Quadro M4000/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 361.91)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 2-8-2016
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.9.18253.21101
C:\Program Files\Rhino 6\Plug-ins\RhinoScriptEditor.rhp “RhinoScript Editor” 6.9.18253.21101
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Users\alr\Downloads\elefront400\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.9.18253.21101
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.9.18253.21101
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.9.18253.21101
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.9.18253.21101
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.9.18253.21101
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\alr\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.8.24.259\SectionTools.rhp “SectionTools”

@djhg, I got your file. In the layout all details are set to use the Wireframe display mode. Which display mode are you using to get this issue? Also, that’s a pretty big scene, I don’t suppose you have a simple file with just one or 2 solids and a clipping plane that causes this?


Driver Date: 2-8-2016

I would start by updating that driver to the current version.

fair enough! but unfortunately it didn’t solve my issue

updated info below:

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-4-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

The three details containing the two elevations and the sectional perspective on the 24x36 layout should be already set to rendered view mode.

Re: smaller project:
I suppose we could use this one and just delete everything but one (or all) of the few clipped objects. Maybe the ground object.

By way of follow-up, I hope it’s worth mentioning that this is may be an important thing to clear up.

Also, I am finding that I can’t count on consistency with respect to the fill’s behaviour. In only a few places will it display in the colour desired. In some cases it will fill in with the surface colour of the object cut. In others it will fill with shadow colour, as if the wall is hollow and full of shadow. Of all the clipping plane aberrations, this inconsistency is the worst, as cut objects will in some places read as dark/solid where the error is to produce a shadow, and in others read as light/open where the error is to use the colour of a light-coloured object.