Rhino 5 64-bit: Maximizing a viewport results in a low-res (pixelated) cached/static view of such viewport



After a viewport is maximized from the standard four-view layout a low-res cached/static view of such viewport is displayed till it is panned, zoomed or rotated.
Even if geometry is being updated either by grasshopper/properties pane/layer properties the low-res cached/static view remains frozen till the viewport is panned, zoomed or rotated.

This behaviour did not happen before probably appearing either after a recent gpu driver update or the installation of Windows 10 Creators Update.

My current setup consists of the following:


  • Windows 10 64-bit 15063.540
  • Rhinoceros 5 SR14 64-bit (5.14.522.8390, 22/05/2017)


  • CPU: Intel Core i7-4500U
  • RAM: 16 GB DDR3
  • IGPU: Intel HD Graphics 4400 (driver version: (
  • DGPU: Nvidia GeForce GT 750M (driver version: 384.94 ( *
  • The system uses Nvidia Optimus technology

V5 sr14 display issues after - creators update
(Pascal Golay) #2

Hello - does Rhino see the Nvidia driver, in Options > View > OpenGL page?





A screenshot displaying the frozen viewport (zoom in the picture in order to appreciate the viewport’s low resolution as compared to the rest of the UI):

(John Brock) #5

Are you getting the same effect and issue in the V6 WIP?


Not tried yet but disabling the Nvidia DGPU via device manager fixes the issue. Maybe it has to do with Nvidia Optimus and the fact that the OpenGL accelerated surface has to be written back to the Intel IGPU memory.

(John Brock) #7

Please try in V6 and let us know what you find.
The development for V5 is closed.
If V6 has the problem, we can probably do something about it.



Ok, I will try this night and report back tomorrow


I have tried the Rhino 6 WIP (6.0.17234.09201, 2017-8-22) and the issue is apparently fixed.
Anyway it is a pre-release software which is not suitable for daily use so the problem is still there until Rhino 6 is officially released.
I love the ambient occlusion on the render viewport style btw.


Smokes… this is my problem as well.
(including some random freezes…)
Did you ever find a solution?

(John Brock) #11

The fuzzy display in Windows 10 fix is described here:

“Random freezes”?
Are you running VRay 3?


I am John.
We’ve already got another thread running, but i was hoping maybe LowEndSilicon had figured something out about the resolution issue. Which I haven’t been able to solve from the link you mentioned, at least not so far… ;S
re-read just to be sure

Just to make sure you understand the issue though.
The fuzziness only occur inside the viewports… not in the actual rhino window.
AND it disappear when moving the viewport around or doing something actively in it… but only the “active” viewport remain in focus
(happens for both v5 and v6… although with v6 it disappear automatically after a 1/2 a second or so)!

  1. Zoomed in (out of focus)
    Screenshot (14)
  2. Zoomed in (in focus), after using the viewport actively
  3. Zoomed out (grid in last active viewport almost gone)
  4. Zoomed out (grid in last active viewport normal) after using viewport actively

And in case the question comes up again (as a bit further up the thread.)
Both my driver date and version is marked: NA

Rhino V5 FREEZE: Win 10 1709, nVidia display adapters, & V-Ray 3

Still no news about this? ;S
GPU and everything else is up to date… nothing seems to fix this…


It only happens with dual GPU systems and started happening after Windows 10 Creators Update. It has to do with the changes introduced in the way accelerated surfaces are transferred from DGPU to IGPU framebuffer. It has nothing to do with Rhino itself.

A possible fix in the Rhino 5 viewport rendering pipeline would be to run a viewport refresh in every viewport each time viewports are maximized/restored.

Rhino 6 is not affected by this maybe due to changes introduced in viewport rendering pipeline.
It is up to McNeel to develop a hotfix for Rhino 5.