Viewport Resolution Errors

Getting some strange viewport errors. when I change from a maximized viewport to 4 view and back to a particular view that is maximized I get a strange over zoomed low res version as pictured below. In the over zoomed viewport selection is off as well by a large amount.

I then right click on
to reset back to 4 view and get full res but only in the 4 view screen. If I maximize one of the viewports they are all still stuck in this overzoomed low-resolution state.

Right now the only fix is to close the file and reopen it. Video drivers are up to date.

Version 7 SR17
(7.17.22081.3001, 2022-03-22)

Rhino 7 SR17 2022-3-22 (Rhino 7, 7.17.22081.03001, Git hash:master @ e429706ef2564517d368a193809c158c4fe9e7b3)
License type: Commercial, build 2022-03-22
License details: Cloud Zoo

Windows 10.0.22581 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 3-8-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
- Secondary monitor attached to adapter port #2
Primary OpenGL: NVIDIA Quadro T2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 3-17-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.15
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.17.22081.3001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.17.22081.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.17.22081.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.17.22081.3001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.17.22081.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.17.22081.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Tommy - so the process is

Maximize a vp
Maximize a different VP

and the view is incorrect, do I have that right?
If that is correct, does switching views without 4View in between work? (i.e. double click in a vp title to restore and then double click in another to maximize, or use the vp tabs to change between maximized views)

I am not getting that here in our latest but I will try 7.17


Hello Pascal,

That is correct. I have also had visual artifacts in the 4 view, I will try and screenshot it when it happens again.

Hi Tommy -

What happens when you only use the laptop’s screen and disconnect the external monitor?

Okay so it happened again and I got this screenshot. Sorry had to blur the work out.

I then went to just the laptop screen and all 4 viewports went black.

I clicked on 4 view and got 3 of the 4 viewports back

And when I click on the tab to maximize any given viewport it goes back to the overzoomed low res.

Hm… can you please check the NVidia control panel and make sure it is set to use ‘high performance’? If not and you set that you may want to close and reopen Rhino if not reboot to test.


Hm Yeah, I guess that looks right - @John_Brock - does this look right for Rhino? It’s not behaving…


@jeff says to run them at “Defaults”, meaning when you install the Nvidia drivers, click advanced, and the “clean install” option.
I’ve not twiddled Nvidia driver settings in many years.

1 Like

Performed a clean install with the newest drivers…still getting the same results however I am working longer before an error. I am also using NewFloatingViewport and Clipping Plane commands on and off when needed.