Rhino 4 won't print to file as JPG

After replacing a defective ram module, Rhino exits the print
command on the last dialog box when save is clicked. All the
settings that come up when the print command is requested are
correct. I am a 14 year user of this software and am sure all
the paper size, dots per inch, preview window appearance, line
width are correct when I click print. The save as box appears
and I change BMP to JPEG, assign a name and click save. The
command returns to the drawing window but no print file is
created. I send large format prints out to a service as JPEG and
occasionally a large group in 8.5X11 paper size. I reinstalled
windows and also Rhino-4 with no joy. I have a newer laptop
running on win-10. I installed Rhino on that as a test with
exactly the same result. I have tried older files that had prints
made from them also no saved file from those drawings. The
file properties have no hidden or read only attributes and full
access is displayed in the file security window. The WIN-10 computer is a brand new 3TB western digital hard drive and
has not been used at all or connected to the internet. I have
never had to install a driver or download anything when upgrading
the Win-XP desktop computer hard drive. I saved a problem file as .DWG and that printed from the print shop computer except
that the dimension leaders point to stuff all over the drawing
after passing thru a common point.

This doesn’t make much sense (ps: I do believe that it happened at that point in time though) since Rhino as a software has no idea about what hardware your OS is handling (other than the OpenGL card) so something else has probably happened together with the bad ram + replacement. Maybe something triggered something within Windows to change. A driver can have been automatically altered, removing a function or something (based on the idea that other machines fails too).

Rhino 4 is 12 years old so there are no updates or support for it, so IF windows altered something Rhino 4 relied on to work, then you are out of luck. BUT that does not mean you can’t produce JPEGS, it just means that you might have to find a workaround.

Have you tried printing to PDF? And then save the pdf from acrobat to JPEG? Opening a pdf in Photoshop will also turn it into pixels. So that might get you going.

Or you can try -viewcapturetofile and set a fixed size to your liking. It all depends on what kind of result you are after. Do you have a file, a screendump or an image of a print that we can see?

I reinstalled winXP on the desktop, reinstalled Rhino-4 and downloaded all of the HP printer drivers. I selected a driver
for a desktop printer and in control panel installed that printer.
The printer showed up in the Rhino print selection box so I printed a file. The print command made a file that was not stored in windows
documents and there was no message of printer not found,
save the file instead. I tried saving as a PFD; BMP rather than
selecting the HP driver I had installed. Still no saved file. I have
another win10 computer back in the US with Rhino-4 that I use
when in country and it works fine. It is set up from my same
Rhino disk 1 CD. I didn’t install the disk 2 on either computer. I didn’t add a printer to the US location computer since I send out
the large format prints there as well as here. I have a HP roll
feed 24" printer in the US which works fine, but my prints are
42" wide so I send them out. The only software on the Philippines win10 computer is win10 and Rhino. This is my backup computer
in case the desktop quits. I keep backups of the drawings on a removable hard drive that could be read into the spare
computer but it has the same problem with not saving a print job.
I would attach a Rhino file but don’t see the paper clip icon. Saving
the Rhino file as a .dwg made smooth curves with screwed up dimensions that printed for P820 ($10 US) The text was out
of scale. I tried cut and paste the screen shot into windows paint
and saved that as a JPEG. At full scale the pixels were just about an inch square.The drawing size is 42" X 124.5" I found the
view/capture/to file and that saved with full scale pixelated images of 1/4 inch with the text and numbers unreadable.
still working on this 10/29/2019 george

Is there not an option in the HP driver itself to set it to print to file? Does it just save it somewhere automatically? I remember doing that sort of thing back in the day. Exporting to DWG or DXF would be my next choice, don’t know why it wouldn’t work.

Trying to print out a 124" long bitmap for a plotter, that seems really unlikely to work, you need like a 450 megapixel file for anything like crisp text(300 dpi.)

Jim, There is a print to file checkbox. There is no place for
custom paper sizes, however the print units to drawing units
lets me adjust to fit on a paper size from a list of stock sizes.
The file saves to the documents folder with a .pn file extension.
I tried opening the file and got a message of what program to
open this file. I tried Rhino and it says file type not supported.
I would classify this as progress in that a file saved from
the print command and could have a file name assigned. I had
downloaded from HP all the printer drivers after searching
for my roll feed HP110 plus r which was not included in the
drivers list of all HP printers. The one installed for the test was
for a Wall Mart HP4400 series we have back in the US. It prints
on 8.5 X 11 size paper. Possibly working harder on the roll feed driver will allow setting paper size.
Our shop builds ornamental iron security grills that are taken
from images in yahoo.search.com/images. The drawings are
done with Rhino-4 and printed full scale with a line width of 5mm
then the iron work is bent to lay over the print lines. We do
coral reef fish, sharks, shells etc. Then there is a tropical flowers series like orchid, lillies, water lotus etc, A tropical plant series,
and currently dragons (european, Chinese, and Japanese) Just
finished were islands of the Philippines with an island and any
thing else in the scene frame. We use JPG because it is a much smaller size file than BMP and it works really well at the print shop.
Well off to hunt down a roll feed printer driver—george

I originally read this as « 14 year old user » and thought you seemed very precocious ! :flushed:

1 Like

Yeah, especially

Our shop builds ornamental iron security grills


1 Like

Update 10/30/2019. Well I have installed several HP printer
drivers for HP111, HP110plus and HP CQ532A none of which
had a paper size adjustable from the print window. Using the
properties tab allowed setting a custom paper size which
changed the paper size in the print preview even though it
was displaying 8.5 x 11 as the paper size. Our HP 110 plusr
in the US does this also but prints. Selecting PNG< FAX <BMP
now displays the paper size window selection and that works.
Clicking print gets the print dialog box and accepts a file name
and the change to JPEG from a default BMP file extension.
Clicking save just returns to the drawing window without the
green status display of saving and nothing is saved.At 74 years
old I may not live long enough to print again. Saving on an
8.5 x 11 paper size with an appropriate printer selected also
does not save. If I had my Rhino-1.1 version disk I would try
that, but it is in the US. That version is still useful because
it opens all CAD drawing files, and even then the loft command
worked as expected.-------george

Have you tried PDF? Illustrator? Viewcatpuretofile at the necessary resolution?

Jim, The drawing resolution is set fairly high because I use
the 3D models to generate G-code for the CNC router used
for casting patterns on things like rotor housings for a 5 rotor
Mazda based rotary engine. The view capture to file needs
the entire object displayed on the screen. Then when it is scaled
up to actual size to print it is very pixelated. (The 12" PDF gets scaled up to 124 inches. ) I also need to print machine shop drawings for a 24 foot diameter exhaust fan we are building
at a scale large enough to fit the dimensions. Probably only
scaled up 3 times from the moniter display.
At this point everything is working except the save
of the JPEG. I get messages at start up that there are critical
updates available for Rhino. I am running the as shipped in
June 2009 version so I may update the next time the message shows up. If it goes sideways I have the install disk for Rhino
with me. It still works because I did an uninstall and reinstalled Rhino when the print issue started a few days ago.
8AM wed here, 8PM tue in the US-----george

Well, I don’t know about V4 but it is possible to specify the resolution. You could also just try a ‘render.’ Of course with the size of image you’re trying to crank out in V4 I’d wonder if you’re bumping into the limits of it being a 32-bit application.

The whole workflow of what you’re doing is a bit baffling, frankly. Why can’t you just get an HP driver to work? I was doing that in the 90s at school.

My drawing resolution is to 4 decimal places and 1/100 of a degree.
The current file is 22k in size with available RAM with programs running is 2.96GB. This computer is running 32 bit, however my
simulator is a 64 bit with AMD Phenom black series 4 core running
liquid amonia cooling on the processor and north side bridge. The video card has 8GB of RAM and is a 2 slot wide with a bunch of
processors. That is air cooled but Core Temp monitoring software
shows it barely working and cool. Somehow Rhino sorts out that
computer and prints fine. The Toshiba laptop in the US shop also works with Rhino-4 and prints fine but we are in the Philippines.
I tried render a couple days ago with the background set to white and got a blank screen. As a test I extruded all the curves
with surface/extrude planer curves/ straight with a distance of
one inch. That rendered and could be saved as a JPEG except
dimensions and text didn’t print. If I explode all objects then I
assume they would also render and be saved. There is then
the problem of getting full scale prints for shop drawings. The
print shop uses things like photoshop but can’t snap to items
in a JPEG image to measure the output to set the scale. The
drawings have a labeled 50CM long test line to verify print scale
after it is printed.
It is my understanding that JPEG stores only objects on the background while BMP also includes all the bits in the background.
Just because I have 3 TB of hard drives is no excuse to store a file that large and the print shop politely tells me to not use that format.
I am assuming the print button in the drawing window is a
function inside of Rhino not a part of windows and that the output
goes thru windows to the print/com port or to a storage device.
Also there is no default print output and a driver must be installed.
A bus ride to Microcad printing/CAD school in Manila may be
necessary to get a brand and model number they use for my 42" wide prints. That driver could solve the ;large format printing but
the 8.5 x 11 also don’t save. Those are just done as scaled to fit
the paper size and for internal use in the machine shop only. I still
need those as JPEG to send to the zerox shop across town.
I had an unreleased version of windows called “Nemesis”
which created drivers for anything you could plug into a desktop.
It also had AI and internet functionality that back tracked a virus
to the sender and encripted their FAT 32 as well as the backup FAT table. Then Win 7 was released and was a much smaller code
so we traded down to 7.

           Ow well back to trying to sort this out----george

Getting closer to a solution. I tried making the paper size 10 x 30
and the print saved. at 12 x 48 it saved but larger sizes didn’t.
changing the dots per inch from 400 to 300 allowed a 33 x 96
size print, and reducing the dots per inch to 150 got the size up
to 42 x 124.5 that I needed. Seems Jim Carruthers was on the
right track with a file size limit issue. Possibly the amount of curves
on this drawing increased the file size compared to drawings
that were 144" for an aircraft wing that has less length of curves.
I don’t know whether I had been using raster format previously at 400 DPI while it is currently running vector format, possibly the
default from the reinstall. Also most of the aircraft drawings had very few lines or were on our shops 24" roll feed HP 110 plus printer. Thanks Jim-----george