RH8 not working anymore

For some strange reason my RH8 stopped getting updates and thus I got a warning of expiration. As I could not figure out how to solve this issue, I decided to delete and reinstall RH8. Now it won’t even load anymore, it seems to be stuck at the startup window:

I cannot create a new model or do anything…

Any ideas here? running macOS 11.3.1

The spinning icon above Initializing... is still moving btw., so it is not frozen in that sense
@dan

Maybe there is an issue with my license - is it possible to log out of Rhino, other than the Logout command, which is obviously not accessible to me now?

Hi Rudi-

Wow, 7 days ago…sorry I didn’t see this earlier.

Normally, we have tests in place to catch this issue, but we’re doing some infrastructural maintenance that is impacting automated testing for V8 WIPs only.

I just attempted to reproduce this on my computer and I can’t. But I am testing with a more recent build. Can you please try with this build?

Better?

PS: It almost looks like there’s a dialog stuck in the background. Did you already try pressing control+up-arrow to see if it’s hidden back there?

thanks @dan, installed the version you supplied, but that did not solve the issue. Furthermore, there area also no other dialogs open…

From Terminal, with Rhino fully closed, try running:

defaults delete com.mcneel.rhinoceros.8

to reset preferences. Then relaunch Rhino. Any luck?

ok that solved it, thank you!!!

Good! Please ping me if it happens again as we’d probably want to take a look at the offending preferences file before it gets deleted.

as I lost all my preferences, I imported the RH7 .plist back in with ImportPreferences again. Rhino then crashed after selecting All for import. After starting it up again, it is now again in the Initializing... loop - only in German now haha
here is the .plist file that I exported from RH7:
RH7.plist (442.6 KB)

Thanks for the plist. I tried reproducing this but I was unable to. Here are my steps…

  1. Downloaded your RH7.plist preferences.
  2. In Terminal, I ran defaults delete com.mcneel.rhinoceros.8 to reset Preferences to factory defaults
  3. Launched RhinoWIP for V8, started a new modeling window, and ran ImportPreferences and selected your RH7.plist.
  4. On the Import Preferences dialog, pressed the Select All button, and clicked Import. Rhino did not crash. (If I’m reading your report correctly, at this point it crashed for you.)
  5. Quit Rhino.
  6. Restarted Rhino.

It ran as expected…and I can see your customizations from your Preferences.

I tried the above steps while running in Deutsch, but it still worked. Sounds like you’ve got a very reproducible case on your end. Let’s figure out what we’re doing differently.

Did exactly the same and it crashes immediately.

I tried only selecting a view options at the dialog. Turns out, that the only option crashing Rhino is the tool palettes option:

When selecting all others and not tool palettes, Rhino does not crash - but it does also not import anything, e.g. aliases are not working…

Even cmd+ctrl+s for Shaded View not working, not even cmd+z.

Unfortunately, I still cannot reproduce this on my machine. I did notice that I’m on a different version of macOS than you reported (are you still on 11.3.1?) I’m going to update to 11.4 soon and test again.