Rhino 8 WIP dxf export & overall stability

after rh8 WIP install, rh7 .dxf export is not working. Also made a program called DeskCnc not work (uses .dxf files to import)- it would not open at all - a blue screen flashed for a split second & then the system was ok - I re-installed DeskCnc & it is working. Dxf Export in Rh7 still not working. I have not tried closing & re-opening Rh7 yet. Also, I have not tried starting Rh8 today after a normal system shut down last night. I read a post about someone trying to un-install Rh8 & then Rh7 would not work. So I am not excited about either running Rh8WIP or uninstalling it . . . Not sure what to do. Seems system is a bit unstable after RH8 WIP install & I forgot to set a restore-point . . . any suggestions would be helpful. Thanks in advance . . . Cheers!

Hi @mcarch I’m sorry to hear you are having issues with the WIP. Pls. run Rhino 7 and send me your _SystemInfo

What do you mean by this exactly?

Thanks Gijs,
I just mean that those few issues (blue screen micro-second flash, dxf export not working (although it is now working fine in RH7) and DeskCNC needed re-installation - Also Google Earth install stopped working - may not be related) ) came up right after I installed & ran Rh8WIP. I still have not run the WIP again yet. I will set a system restore point maybe and try it again. Or maybe try installing it on another machine I have . . . Thanks again for your assistance.
Rhino 7 SR27 2023-2-1 (Rhino 7, 7.27.23032.13001, Git hash:master @ 4a0030c0d354560df03764f4f49ecc5d119e5118)
License type: Commercial, build 2023-02-01
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 4000 (Intel) Memory: 2GB, Driver date: 8-16-2018 (M-D-Y).
> Integrated graphics device with 2 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA Quadro K5000M (NVidia) Memory: 4GB, Driver date: 12-29-2016 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 376.54
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.5 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 12-29-2016
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\packages\7.0\LadybugTools\1.38.0\Ladybug.RH.Loader.rhp “Ladybug.RH.Loader”
C:\ProgramData\McNeel\Rhinoceros\packages\7.0\Pollination\1.23.0\Pollination.RH.Loader.rhp “Pollination.RH.Loader”
C:\Program Files\Scan&Solve Pro for Rhino 6 & 7\SnSPro_Rhino_6+7.rhp “Scan&Solve Pro for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.27.23032.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Mike Calvino\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Your video drivers are awfully, awfully old… 2016 for the NVidia…!

could that be causing the issues I’m talking about? No newer drivers available for this machine . . .

there are drivers from 2020/2021 (DCH/Standard) for that card, I am running 392.68 on my win10 dell precision with a k2100m


Thanks jdhill . . . I did update driver for the nvidia. it only updated to the 2018 driver. I tried installing the newest one, but it would not install saying my version of windows will not accept the update. my machine has an old Intel core i7 3940xm & it has been & still is a workhorse - spins up to 3.8ghz & outperforms quite a few newer processors still, plus I cannot justify a newer machine that would outperform it yet. So I think that may be why my windows will not take another update. version 22H2. I have not looked into it any further but may benefit from that when I can make some time to do it.

I have run WIP again, just updated it yesterday after setting a restore point. seems to be ok & running well now. DeskCnc worked fine, so that issue seems to be gone. I like the updates made to SectionTools (ClippingPlanes now) they seem to work better & more quickly. Thank you all for input.

if it is working then I’d probably leave well enough alone, but if it decides to act up some more, then just know that depending on your OS, you may need to choose either the Standard or DCH driver type in that search page, with one or the other not being compatible and refusing to install

yes, good advice. thanks. I updated the k5000m from device manager & it automatically updated it to 382.16 - looks like from 5-9-2017. I may try installing the latest Standard driver later on (not sure, but I think I tried the DCH first) , but we’ll see. seems to be working ok, so I may leave it alone.

I’ve had no more trouble yet, been using WIP since Friday. So far so good! Thanks to WIP team . . . forging ahead.
Nvidia Driver will not take an update beyond 382.16, but seems to be ok.