Rendering curved surfaces in vray


#1

My curved surfaces are rendering with jagged edges. I’ve played with a number of settings in vray but have clearly not hit on the correct one yet. The white object in the middle should be a circle and the brown object at the front edge should be a smooth arc, rather than stepped. Suggestions? Thank you.


#2

Those artifacts look like your meshes are literally miles from the origin, is that the case? Do they look like that in Rhino’s viewports?


#3

They look smooth in the viewports. However the linework to create these objects was imported from microstation, so is far from the origin.


#4

That’ll do it.


#5

I moved the whole model to 0,0,0 and rendered it again to get:


(Marc Gibeault) #6

Then it must be your render meshes settings that are too coarse.
Go to Tools->Options->Document Properties->Mesh and select something different than Jagged & faster.
Here are my settings:


#7

Well, if they were meshes imported from Microstation, they might not be fixable… If mesh objects are created far from the origin with single precision and are jaggy, moving them close to the origin will not fix them, as meshes are not “remeshed”… We’ve had this happen with stl’s that are created in Rhino far from the origin, nothing can be done to fix them, the original has to be moved to the origin and a new stl has to be created.

I hope that’s not your problem here…

–Mitch


(Brian James) #8

Hi All,

FYI, this came into tech as well today. The active Cplane was not the world top and so 0,0,0 was not at the actual world origin. This was causing the render mesh to be offset and just plain messed up. I believe it’s due to Rhino render meshes being single precision at this time. Moving the model solves the artifact.