Jagged Surfaces in Rendering

Hi all,
I have got jagged surfaces when I try to use the default rhino render.
The model should be like this

While when I tried to use the default render in Rhino, it turns like this

I’ve tried to switch the ‘render mesh quality’ to ‘Smooth and slower’ in OPTIONS.
Please let me know what happened and if that’s something about my hardware problems.

Thank you all!

Hello - most likely the objects are way out in space. Moving them to the World origtin and running ClearAll Meshes, should sort it out. Let us know if not.


Thanks for the quick response.
I’ve tried another view which is more close to a standing view and tried the ‘CLEARALLMESHES’. While the problem still exists.

But I fixed it by enlarging the model 10X, since the threads are too thin to be rendered. I guess that’s the problem.

Thanks again!

No that looks very much like what Pascal said, your model is probably literally miles from the origin? Maybe scaling will help somehow, but…that’s the basic problem.