My curved lines are not curved!


#1

Hello everybody !
II made beautiful curved lines for my project, but when I want a rendering, they are all split up … Like on the enclosed document. I’m a beginner with rhino and V-ray so don’t laugh at me if it’s an easy issue :wink:
I use rhino 5 and Vray 2 and I don’t really know where it could come from


#2

Are your objects located literally miles from the origin? That’s what that looks like–double-precision NURBS are capable of representing the whole solar system down to molecule precision, the render meshes aren’t–though I would have thought it would show up in your shaded view too.


(David Cockey) #3

Refinement of the render mesh needed?


#4

First, thanks a lot for your answers.
Then, I tried to change the render mesh properties but it doesn’t change much … (see enclosed screenview) do I have to change something else ?
I’ve made my project using “loft tool” so my surfaces are meshes or NURBS ? do I have to change ?


(Marc Gibeault) #5

As Jim said, check how far from the origin the geometry is.


#6

Your surfaces are NURBS but no matter what you do in Rhino things can only be “displayed” as a mesh.

Like everyone else is saying: how far from the origin is this? Its really nice to work in world co-ordinates like Northings and Eastings but this can be millions of units away and it introduces rounding problems. It is best to work with a locally defined origin


#7

I’ve redifined the origin so it can be really close to the model. But still, the problem is here.
I was wondering if there could be something with the scale of the drwaing ? I’m working in millimiters, does it chagne anything ?


#8

Yes, if your distances go into the millions of units


(Marc Gibeault) #9

Changing the origin by creating a CPlane near your geometry won’t do. You have to move your geometry near the “world” origin.


#10

and how can I find the “world origin” (haha, I never thought I would be looking for it one day !)


(David Cockey) #11

How did you change the render mesh settings. From the image you posted it appears that you used “Custom” with zeros or all settings except Minimum edge length which is set to 0.0001. My understanding is the zeros result in the default settings so you may not have made a significant change to the mesh.


(Pascal Golay) #12

The world origin can always be located with W0,0,0, so for example, if you want to move an object to the world origin, select it (them) start Move, and snap to some point on the object that you want to have on the origin as the point to move ‘from’, and type in W0,0,0 as the point to move ‘to’. Then Zoom Selected to bring it into view.

-Pascal


#13

The easiest way to guarantee it is to place a point at w0 (letter “w” followed by the number zero “0”)

Command: Point
Location of point object: w0


(David Cockey) #14

Pascal provided a better answer.


#15

The short hand version for lazy people like myself is just 0 which represents the 0,0,0 (long form)


#16

Ok, So I took my object and put it in a new file, on the origin. I scaled it because it was 1000x too big and then the render was good ! So you were right about the source of the problem
So now I’ll try to put my object on the origin of the first file as you told me to do.

Thanks a lot for your help. I wish there is no distance between us so I could thank you for real