Rendered Display problem and workaround


since a few months I have problems with blocks and the rendered display, backfaces and some times front faces are not shown. I suppose so the problem is known but not easy to fix.

Today I found if I edit the shaded mode so that rendered material with textures are shown than anything works fine. So I can share screenhots with my clients again. :slight_smile:


@DavidEranen, something interesting for you perhaps…

Hi Micha,

Can you describe a step-by-step process for how to repeat the issue, and exactly what the visual problem is? It would also help to know what computer and OS you are running.

A screen shot would also help.


Attached two rendered display modes - one buggy and one working.

RenderedShaded.ini (11.5 KB)
Rendered-Buggy.ini (10.4 KB)

Tagging @BrianJ and @jeff in case they have heard of this issue and have workarounds.

I was able to reproduce the bug in v5, but not in WIP.

@DavidEranen How were you able to reproduce it? I’ve imported the buggy mode into my V5, and so far everything displays as expected… Note: The buggy rendered mode pretty much has all defaults turned off…not really a “rendered” mode at this point…

Post an example 3dm file that looks bad using the buggy mode. But since this doesn’t seem to happen in V6, it’s probably a moot point.


Hi Jeff,

I sent a model to David, I will send it to you too. I disabled the most render features because I’m looking for display speed and I need it to check the scene for rendering only.

Right, it’s not so important, since I found a workaround and it works at v6. Only I afraid I could stick at v5 if v6 should be slower for complex models.