Render displays no shadow


#1

hi there,

i’m quite new to using rhino 5 as a visualization tool. hopefully there is someone out there helping me out with a quite standard render issue.
i just want to display a simple shadow on my floor object, but i must miss something quite simple.

i’m using rhino 5 edu/ standard rhino render.


(John Brock) #2

My guess is the problem is video driver or configuration related.
Please go into Rhino Options - View - OpenGL and take a screenshot of the settings there.
Please return the image in a reply.
It should have the details needed to make a suggestion.

Thanks


#3

hi john,

thanks for your reply. please have a look.

i run rhino within parallels on os x


Sun Path Diva
(Wim Dekeyser) #4

See this post (among many others):


#5

hi wim, thanks for your reference.

but i also use rhino native on win 7 via boot camp. and i have the same shadow issue when running without virtualization.


(Wim Dekeyser) #6

Could you show us a screen shot of the setting when running under Bootcamp?


#8


(John Brock) #9

Reverse the check marks.
Check using accelerated hardware modes and uncheck the other three options.

I hope you are running a supported graphics card. If you’re not, that would explain perhaps why your options setting and not default values.

When the first option is left unchecked, then Rhino makes OpenGL calls to Windows emulation that is OpenGL version 1.1. Rhino shadows require OpenGL 2.0 and Shader 1.2


#10

hi john,

i changed (cheked/unchecked) the options. now there a different information displayed. but still no shadow. another idea?


(John Brock) #11

OK, that’s why the accelerated hardware was unchecked. You’re running an unrecommended Intel graphics chip. When Rhino detects the Intel chip, it disables the accelerated hardware option. This is covered in the Rhino 5 System Requirements:
http://www.rhino3d.com/new/admin#system
http://wiki.mcneel.com/rhino/rhino5videocards
It looks like you chose a computer for Rhino without checking what Rhino’s requirements were.

If the shadow feature is important for you, you’ll need to get a different laptop computer with an AMD or Nvidia graphics card that supports the OpenGL and Shader requirements of Rhino V5. If you’re running a desktop, then you can probably install a supported graphics card.
Sorry.


Coarse Interface / Toolbar Generation
#12

argh ;(((

i’m working on my shiny new mac book pro retina 13"
to me this is right now kind of worst case.

but thx for all your help!!! john and wim


(John Brock) #13

The 13" MBP Retina is a nice machine for Mac Rhino but a terrible machine for Windows.


(John Brock) #14

If it’s still new, maybe you can trade it for a 15" model with the second graphics chip.
Many of the techs here in Seattle are running 15" MBP Retinas.


#15

jep, i run the machine now round about 12 weeks. i think it will be a quite painful exchange…

anyway, i just want to tell all you guys: thx for this great forum. nice tone, helpful and fast!!!
Dankeschön :wink: