Shadows missing from rendered display mode

unhandled

#1

In rendered display mode, none of the objects in my model cast shadows on one another or on the ground plane. “Casts shadows” and “receives shadows” are checked in all of the object properties. None of the materials are transparent. The sun is turned on. The shadows do show up when I raytrace with Neon, but I’d prefer not to use Neon because it is producing some weird stripes on cylindrical objects in the model. The “current renderer” is set to Rhino Render.

Possibly related: when I turn the skylight on or off it doesn’t appear to make a difference.

What am I missing?

Thanks for your help.


(Willem Derks) #2

Hi Matt,

Did you y any chance turn off shadown in the rendered display mode?
To check echter go into Rhino options or faster via the tab-panel for display mode:

HTH
-Willem


#3

I have the same problem, even though all shadows sign are V checked. Is there any possible additional reason ? thanks


(Willem Derks) #4

Hi Rachel

It could be your videocard (GPU) is not up to the task or it is for some reason turned off.
What GPU do you have?

HTH
-Willem


#5

WOW !!! THANK YOU SO MUCH !!!
It was exactly what you said - “Use accelerator hardware” was not checked.
And now everything is fine.
Thank you so much for your help
Rachel


#6

Willem,
Sorry so long to respond. Thanks for your help! Turning on the accelerated hardware setting solved the problem. This forum is great.

  • Matt

#7

Hello, I have the same problem, but already have checked option “Use accelerated hw modes”. What else can be wrong? I use macbook pro with Iris pro GPU (running windows 8).


#8

Hi, I’m having this same problem, and I checked everything of the above but it still doesn’t display shadows on Rendered display o any other display mode…

If I render, the objects do cast shadows though. So I think this is a display problem…

Please help!


(Pascal Golay) #9

Hi Nicole - it looks like the viewport behind the dialogs is showing cast shadows…? What;'s the black?

-Pascal


#10

The black is just the built geometry itself, but it is not casting shadows over the “ground”…


(Pascal Golay) #11

Hi Nicole - OK, yes, thanks, I see it in this view - well, your video support is on that great here - I am not sure if the 4000 is expected to work for shadows but you could try boosting the memory available to shadows in the options.

-Pascal


#12

Thanks… Thanks… tried that but no change. I tried all the sliders in fact… Only modifying the “bubble” some shadows appear… but not sure if thatás the correct way to do it


#13

I’m having this problem. I believe I checked evertything suggested above. Noticing that spotlight and point light display cast shadows whereas rectangular light does not- neither does linear light.

Can anybody get cast shadows on this model? Thanks.
https://1drv.ms/u/s!AmEW-HsXOJs0qy9h5JvCa4zs8G9h


(Pascal Golay) #14

Hi Michael - in Rendered mode that is actually expected as far as I know - these lights are not supported in the openGL preview - but a full render should work…
-Pascal


#15

Thanks, Pascal.


(Loreto Ramonsolans) #16

Hello All, I am actually having problems with the shadows also in rendering mode. I have done all the things you have suggested but it´s still not working. I would truly appreciate if anyone could help me as I´m desperated. Thanks a lot!!
Any suggestions???


(Pascal Golay) #17

Hello - are the materials all set to use self illumination? It looks like they might be.

-Pascal


(Loreto Ramonsolans) #18

Thank you very much for the instant response I really appreciate this.

How can I check this?? The problem is that when I render it the shadows
show up, but in rendered mode they don´t that is what I don´t understand.
Also its a bit weird because sometimes they show up when I play with the
Camera based Clipping Buble but only in a fixed view,and in certain
objects, if I move the view a bit then the shadows dissapear.


(Pascal Golay) #19

Hello - I’ll just guess for the moment that the scene is too large - if you hide all but a relatively small part of the scene do shadows come back?

-Pascal


(Loreto Ramonsolans) #20

Still doesn´t work…