Render Content Name Conflict


#1

We have been noticing this warning which appears to be new in 6.4:

image

We are getting this constantly when I run a script that imports a template.

Is there something I need to watch for in the template files? Perhaps something I can change to eliminate this message. Or is there a setting in the advanced settings to shut this off?

Thanks,

Dan

edit: It seems like it’s just a matter of purging materials out of the template files. I think I have this one solved.


#2

I’m working on car models with many external linked 3dm files as blocks. Many of these files shares the same material, e.g. a door handle and a rim with a ‘chrome’ material. When I open the car file, the ‘Render Content Name Conflict’ warning pops up for every external file that creates a conflict. It’s pretty annoying to specify which action I want to perform for, lets say, 20 times before the file loads completely and furthermore, checking the box with the ‘Do this for any further conflicts during this command’ statement doesn’t seem to have an effect.
Am I the only one having this issue?


(Ncruz) #3

I’m having the exact same issue as Samuel except I’m working on models of boats. I import many external linked files as blocks to reduce my file size. For me, there are more like 30-40 conflicts that I need to click through. Even after going through this process and saving the file, the next time I open the model I get the same message. Never had an issue on Rhino 5 with importing blocks.


(Pascal Golay) #4

Hello - are you referring to block name conflicts or render material name conflicts?

-Pascal


(Ncruz) #5

I get the exact same “Render Content Name Conflict” that DanBayn posted. The window also shows up when I simply import an object, not as a block.


(Ncruz) #6

We just upgraded over 30 seats to Rhino 6 and everyone else is getting the same popup window…over and over and over again.


(Nathan 'jesterKing' Letwory) #7

This problem has been fixed in the 6.x branch, meaning it’ll be available with the first 6.7 release candidate in about two weeks (final 6.7 in about 6 weeks).


(Ncruz) #8

Awesome! I’m looking forward to that release. Thank you!!


(John Croudy) #9

I’m sorry to hear about the pain this issue is causing. I have a possible workaround which may help until SR7 is released. If you make sure the Environments panel is open before doing any imports, the problem should not occur at all. I hope this helps while you wait for the update.

John


(Ncruz) #10

Oh no worries. Bugs are inevitably going to happen with any new software release.


(Djhg) #11

I am having this issue in a current project, SR8. Checking “do this for all name conflicts in this command” (or whatever the precise wording is) doesn’t prevent them from repeating while the project is loading.


(Ncruz) #12

I’ve been meaning to reply for a while. I’m still having the issue as well. Another one that pops up is block name conflicts. That isn’t nearly as annoying as having to click through 50-60 (no exaggeration) render content name conflicts on some projects.


(John Croudy) #13

Several weeks ago I added a new check box to this dialog: “Always keep the existing item; do not show this again”. This check box should make the dialog go away forever. It can be restored by using the ResetMessageBoxes command. This change is in SR9. More information is here:

John


(Djhg) #14

That’s good, because “Do this for every conflict during this command” has no effect.


(John Croudy) #15

It does have an effect when there are multiple conflicts during a single command, for example a single Import. But I didn’t realize that there could be multiple commands inside a script. This is where it has no effect, because the script keeps starting a new command. This is why I added the option to get rid of the dialog forever.

John


(Ncruz) #16

John
We’ve been updating our companies multiple licenses to SR9 and this has fixed the multiple popup window issue. Although now, a new one has arisen as a result of this update. A lot of us have the Flamingo plugin and Orca 3D, which we would rather not have enabled with every open model. The new check box, “Always keep the existing item; do not show this again”, that was added to the render content name conflict automatically turns on these plugins. Is there any way to seperate this command from the enabling of plugins?


(Pascal Golay) #17

Hello - that does not seem right… I’ll see what I can find out.
@johnc - is this something in your zone, or… ?

-Pascal


(Ncruz) #18

I may have jumped the gun, it happened to me with one model and it messed up my render properties. It’s entirely possible that I accidentally enabled Flamingo. Opening other models, I do still receive the “Rhinoceros 6 Load Plug-In” screen.


(John Croudy) #19

Hi Ncruz,

I’ve been puzzling over how this could happen. The ‘Don’t show this again’ thing is just a marker in the registry that is checked before displaying the dialog. It doesn’t (or shouldn’t) do anything with plug-ins. Has the problem stopped now?

John


#20

where is that setting stored? Like to set that for our customers to avoid the render conflict dialog