Render Content Name Conflict


(John Croudy) #21

On Windows, the setting is stored in the registry. If you want to change it:

  • Run regedit.exe.
  • Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\DontShowMeThisDialogAgain
  • Add a new string value called rdk.RenderContentNameConflictDialog
  • Set the value to NO

Perhaps easier would be to copy the following text to a file called TEMP.REG and then open that file, which will have Windows add the key to the registry automatically.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\DontShowMeThisDialogAgain]
"rdk.RenderContentNameConflictDialog"="NO"

I hope this helps. Please let me know if you have any problems.

John


#22

thanks, yeah, never would have found that, was looking in reg rhino sections.


#23

hi @johnc,

This dialog is one of the most annoying things here in Rhino right now, we must be seeing it 100s times a day, with several clicks to make it go away. We basically 99% of the time want to Auto-Rename all.
Now, even if this is switched on as Radiobutton, we still need to check the box “do it for all conflicts”, then click “Auto-Rename” button…

NameConflict

At minimum, it would be helpful to make this checkbox sticky.
Even better, since you offer an option to forget this dialog and always keep existing, how about the option to always Auto-Rename?

Or ‘always for current session’ (I’m OK clicking this dialog 2-3 times a day). Somehow making it go away forever has a potential to unintentionally mess things up, that’s why I like the per session option. But in general, we need a way to make Auto-Rename All stick.

Hope you can consider improving this little dialog, it would save a lot of time and extra clicks.

thank you,

–jarek


(John Croudy) #24

Hi @Jarek

I’m sorry this dialog is causing you so much pain. I’d be happy to look into improving it some more. Thanks for your suggestions. I’ll look at it during the coming week.

Regards,

John


#25

hi John,

thank you , I appreciate you looking into that!

–jarek


(John Croudy) #26

I have filed this bug report: https://mcneel.myjetbrains.com/youtrack/issue/RH-50817


#27

hi @johnc

the new dialog works like a charm and is exactly what it should be I think.
Thank you for making this much more streamlined process. Looking forward to not seeing this dialog more than once per session!

–jarek


(John Croudy) #28

@jarek I’m glad it’s working for you. Thanks for your help.