RE: Question About Exporting Meshes - Is There a Difference Between Automatic Meshing and 'Mesh form Surface/Polysurface' command?

I recently had to export a large model made in Rhino 6 to 3DS file format and had issues. I found a workflow that works, but I do not understand why it works and why the original workflow did not work. I am posting here to ask, can anyone explain this issue to me?

I have a large topographic mesh model (~3000 ft x 1000 ft) with several large polysurface buildings and mesh buildings on it, as well as a lot of civil hardscape features, that I needed to export to 3DS file format for someone else to use.

First, I ‘selected all’ in the model, chose ‘file>export selected’, and then exported using the 3ds file format, setting the polygon mesh options to default. During export, the export function ran for several minutes, then the command line annotation changed from saying, “Created a mesh with x points and y polygons.” to some message about ‘splitting meshes’. Then the process hung up and never completed.

So next I decided to export the model as an OBJ and convert to 3DS in another program, but the exported OBJ had flipped normals in many places. I then tried exporting as FBX and as Rhino 5 and using various programs to open and convert the files, but all had flipped normals or other issues in all cases.

Finally, I went back into the base model in Rhino 6, selected all, then selected the ‘mesh from surface/polysurface’ command, accepted the default settings, converted the entire model to meshes, deleted all polysurfaces, saved, and then tried to export to 3DS file format. It worked perfectly and quickly.

Why did the ‘mesh from surface/polysurface’ command work but the meshing function that is part of exporting to 3DS did not?

Hello - there are two things that come to mind - first, are the meshing controls set exactly the same way?
Secondly, 3ds has a 64000 triangle limit for a mesh - that is what the splitting message is about - but does not explain what it hung.


Yes, they are. That may explain the splitting message. But then that means, presumably, that when I ran the ‘mesh from surface/polysurface’, Rhino created a mesh with less polygons. I wonder why that is.

Hello -

if you have an example file that shows the problem, please send to to my attention, along with a link back here in your comments.