Rhino 8 SR8 Release Candidate 1 (8.8.24135) CRASHES after startup

Hi all, anybody experiencing trouble with latest update?
Just updated to 8.8
started the app which loaded in ~10s
then it hangs 20~30sec and crashes.

tried to start with default 3dm template, crashes as well

loaded only in SAFE mode,
disabled all plugin that do not ship with Rhino
tryied again but keep on crashing at startup.

Rhino 8 SR8 2024-5-14 (Rhino 8, 8.8.24135.14001, Git hash:master @
License type: Commercial, build 2024-05-14
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.19

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 SUPER (NVidia) Memory: 8GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: (null)
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0
- Secondary monitor attached to adapter port 1

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL (null) (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 4-11-2024
Driver Version: 31.0.15.5222
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24135.14001

1 Like

Hi Luca -

Have you tried a “Repair” of the installation through the Windows Control Panel?

Also, do you still have the installer for the previous version that you were running? If you are automatically downloading updates, that should be in one of the subfolders in %userprofile%\Appdata\local\McNeel\McNeelUpdate\DownloadCache\
-wim

Hi Wim,
I am after some deliveries.

I just unistalled 8.8 and installed a fresh 8.7 from download center setting update interval to SR.

Will update again next week and see what happens,
thank you for the prompt reply!

1 Like

Hi Wim,

I installed 8.8
crashed again.

repaired the installation
restarted
checked for windows update
started Rhino:
loaded in ~10s
then it hangs 20~30sec and crashes.

Hi,

yesterday had almost same issues opening all of my existing files. i had a problem with a “non shipped with rhino plugin”, in my case was safelayout.rhp

i disabled all of my “external plugins” and rhino worked all right. I enabled them one by one an identified the origin

Yes, there does seem to be a problem with this plug-in and the latest SRC.

This was a great plugin but it is not actually needed anymore, given that this functionality is now included in v8.
It was already switched off. Is it supposed to cause crashing even so?

Hod Do i get rid of SafeLayout for Rhino 8?

Disable it. In my case after taht i did not delete it from my HD because i need to work between v7 and v8

If Rhino does not succeed loading I cannot open Rhino Options.
But It was already set to off.
I am not using Safelayout with Rhino 8.

Did you try to load rhino in safe mode? does it work?

Yes,
Rhino loads in safe mode.

disabled alla plugins which does not ship with Rhino
but Rhino still crashes.

Hi -

Steve and Curtis have been fixing a few things during the last 24 hours and if these fixes are tested and found good, it’s likely a new 8.8 SRC1 will be released soon. For the time being, staying on the stable 8.7 is the work-around.
-wim

1 Like