R7 Italic text fail when print to Rhino PDF

Hi,

I have this issue since R6. Some italic text don’t show as italic when in Rhino PDF. However, I tested several fonts and found some fonts do work. But now it seems all fonts are failing in R7. Can someone explain what’s going on?

Thanks!

The bottom left from the screenshot shown is the pdf result.

Hi Hogan - Please run the SystemInfo command in Rhino and copy/paste the results here.
If you can export some of that bad text to a new file and post it here, that would be helpful.

-Pascal

Hi Pascal, here you go

Rhino 7 SR5 2021-3-15 (Rhino 7, 7.5.21074.17001, Git hash:master @ 1e1438fea51381ad60d1d79103adb6c3a216e4a2)
License type: Educational, build 2021-03-15
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3080 (NVidia) Memory: 10GB, Driver date: 3-25-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 465.89
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-25-2021
Driver Version: 27.21.14.6589
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 10 GB

Rhino plugins that do not ship with Rhino
C:\Users\hogan\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21089.1448
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020” 1.0.6.0
C:\Users\hogan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.1\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.6.1.0
C:\Users\hogan\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21074.17001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Italic font fail.3dm (3.6 MB)

Thanks I see that here as well. It seems to be that font, and only in vector output - if I change some characters to Arial, the italic is respected on those in vector.

RH-63873 Print: Italic is ignored in pdf

-Pascal