Font substitution when printing to PDF

Hi,
sorry to revive such an old thread,
I had the same problem earlier today and i tested it with Rhino PDF as well as Adobe PDF. My font of choice is Maison Neue and it reverts to Courier.

Can you please supply a sample file?
Does the vector/raster setting make any difference?

Hi John, thanks for replying, raster mode keeps the fonts as intended in both plotters- adobe PDF and Rhino PDF.
Vector Rhino PDF keeps the fonts as intended as well. Adobe PDF has the highighted tickbox checked by default under properties. unchecking that seems to have fixed the problem for that plotter. I hope this helps someone else as stupid as me in the future :wink:
image

layout test.3dm (275.0 KB)

Rhino WIP 7.0.20231.16005

System Info

Rhino 7 SR0 2020-8-18 (Public Build, 7.0.20231.16005, Git hash:master @ 58f0ee664bd3c34b972266f3f3bdb1de4c3bebcf)
License type: Edukacyjna, build 2020-08-18
License details: Cloud Zoo
Expires on: 2020-10-02

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 6-21-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.48

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-21-2020
Driver Version: 27.21.14.5148
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\USER\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.1\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.1.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.0.20231.16005
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20231.16005
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20231.16005
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20231.16005
C:\Program Files\Rhino WIP\Plug-ins\export_PDF.rhp “PDF Export” 7.0.20231.16005
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20231.16005
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

skala.3dm (60.6 KB)

  1. My font keeps on changing when I want to print to vector, although I use Rhino PDF as a printer.
    I noticed it with one font family (but didn’t test a lot more with others). It was installed in Windows in otf format.

image

If I choose Cocogoose Pro SemiLight or Light, in the viewport it looks fine, but prints to vector as Italic

LAYOUT:

VECTOR PRINT PREVIEW & PRINT:


  1. I took me a while to realize why raster print preview is in the wrong size, doesn’t fill the layout - a bit confusing stuff.

  1. For some reason, I got a strange lag when changing the font to Arial. It doesn’t change (although it shows Arial as a selected font). I must select different font first and then change it to Arial.

I do not have that “cocogoose” font set.
A Google search tells me it is available in a lot of different places.
Can you tell me where you got yours?

Also what PDF printing tool are you using?