Rhino 7 Installed fonts not appearing

I’m using the evaluation version of Rhino 7 and I have a bunch of installed fonts that aren’t appearing as options. I’ve found that immediately after installing a new font in will appear in Rhino for use, but the next time I go to use Rhino it will no longer appear. I’ve been working around this by closing rhino, reinstalling the desired font, then reopening rhino. This method works but is obviously not ideal. Is there some other way I should be installing my fonts to insure they appear? or is this just a bug that needs to be fixed?

1 Like

Hi -

I don’t think we’ve run into that issue before.
Are these standard fonts that come with the factory-default Windows installation?
If not, can you post a font that behaves like that on your system?
Also, please run the Rhino SystemInfo command and copy-paste the result here.
-wim

It doesn’t happen with the default fonts, but it does with any additional fonts I install. The new fonts will work in Rhino until I restart my computer and then they will no longer appear even though they are still installed and work in other programs. examples of fonts it’s happened with are DS Etienne Font · 1001 Fonts and Morris Roman Font Family · 1001 Fonts though again it seems to happen with any font that is not a Windows default.

the system info:
Rhino 7 SR4 2021-3-19 (Rhino 7, 7.4.21078.01001, Git hash:master @ a432d22ab7f0f7b53d157d578278070c8bf6eff4)
License type: Evaluation, build 2021-03-19
License details: Stand-Alone
Expires on: 2021-07-01

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 7.8Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 6-4-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1050 (NVidia) Memory: 4GB, Driver date: 6-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.23
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-24-2019
Driver Version: 26.21.14.3123
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Wonder if this issue has been solved… I have some additional fonts installed on Windows that work fine in Rhino 5 but do not appear in Rhino 7. Any ideas?

I had this issue last week, I installed a font for a specific custom made template. Each time I started Rhino the pop up box appeared telling me ‘missing font’. It appears Rhino is trying to install this font on all the other templates in the system :woman_shrugging:

Hello! I am having thew same issue. I just upgraded from rhino 5 to 7 on a Mac. Worth noting I have switched computers as well but have uploaded the new fonts to my font book. I use Graphik for my work and the original graphik shows up but none of the sub fonts, ex semibold, light, etc. I have written in via email but wanted to see if anyone figured out a solution here?

1 Like

I’m not sure of the cause, but if it were me, I’d reset my Rhino PLIST and let it build a fresh one.
https://wiki.mcneel.com/rhino/mac/resetprefs

1 Like

It’s march 27th -2023 and I have the same problem. Does anyone have a solution?

Here is my systeminfo:

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Educational, build 2023-02-27
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [80% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 12-22-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 528.02
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1

Secondary graphics devices.
Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 7-11-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-22-2022
Driver Version: 31.0.15.2802
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
E:\PROGRAM DEPO\3D\Rhinoceros\Plugins\RPTool - R6 R7\rptool.rhp “RP_Tool” 0.0.0.0
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 5.0.3.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\export_STL.rhp “STL Export”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I didn’t have this problem until the last Rhino 7 update I guess. Or maybe related to Windows 11’s updates. I need to admit that I HATE this feature of windows that they MAKE you update, even though you don’t want to.

I don’t know if this is relevant but I see that 2 fonts that has the “Font embeddability” option set to “Print and preview” are not visible inside Rhino 7’s TextObject dialog. Also don’t appear in the “Text” command’s dialog box.

NOTE: Rhino 5 sees the font. I could work with importing it in R5, copy it and then paste it in R7. But I may not always have R5 with me. I’m sure it is a simple fix.

NOTE 2: Rhino 6 latest build, doesn’t see the font either…

Hi Erdem,

I think the “Print and preview” value is a red herring: I have fonts with that categorisation and they appear normally in Rhino.

However, I am wondering where you downloaded your copy of Bangers from. My copy, downloaded from Google Fonts, is different, showing an embeddability of “Installable” and an icon with the letters “ABG” and appears in Rhino. If you downloaded from another source, it would be interesting to see whether the Google version makes a difference for you.

Regards
Jeremy

Hi Jeremy, thank you for the response.

This is interesting. I need to try some google fonts. But they worked before. I’m trying to figure out if this is a Rhino bug or a Windows bug… How updates can be outdaters sometimes… :confused:

I have the same problèm .

Hi Sylvain -

Please post a link to the font that you are having problems with.
Also, run the Rhino SystemInfo command and copy-paste the result here.
-wim

I had that same problem, it drove me crazy, but I found out that this is not rhinos fault.

it is about the way you install the fonts. when you just select them and right click to select “install” in win 11 - that is not enough. that way the fonts only get installed for the current user. rhino needs them to be installed for all users.

what you need to do instead is to select them, right click, go down to more options to access the old menu and there click install for all users. this should work.

there might have been other steps necessary in some cases but I don’t remember that out of my head now.

1 Like

did the “install for all users” help?

1 Like

Thank’s for the help, i try it

1 Like

Yes it works thank’s a lot

1 Like

Could you solve it? I also have a Mac but t is for work so I need my “Administrator password” for everything I do. I would rather know if it was solved before I ask for help from the IT team.

Thank you