Rhino 6 terribly slow vs Rhino 5 with same file

Rhino 6 reacts very slow in a big file on my pc, where the same file in rhino 5 is no issue. Same plugins installed, newest version on both…

system info:
Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Intel® HD Graphics 4600 (OpenGL ver:4.3.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build
Driver Date: 8-16-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Users\friso\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\OctaneRenderForRhino (f109bd23-4cf3-4c0b-9f83-06be474b0152)\\RHI Installer 6\Rhino 6.0\x64\OctaneRenderForRhino.rhp “OctaneRenderForRhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

There is also a titan X video card installed, which is only used to render with octane render. Any ideas what could be the issue?

tried sofar:

  • reinstalled rhino6
  • reinstalled video drivers
  • turned off anti-aliasing
  • purge on file / remove dup objects
  • hide meshes in viewports

Have you tried running Rhino so that the Titan X is the primary, used GPU? The Intel HD Graphics 4600 isn’t exactly the most powerful GPU out there, and with Rhino 6 demanding (much) more of the GPU than v5…

Hi, thanks for thinking along. Sorry, forgot to mention that indeed I’ve tried that too. No difference though.

Hi @fjg85,

Just to make sure we’re on the same page: Have you managed to get Rhino to report that it is using the Titan X?

Which display modes are slow?

Would it be possible to send us the model that is problematic? You can do so confidentially through this link: https://www.rhino3d.com/upload


Hi @DavidEranen, thanks for your support.

Yes indeed, I’ve changed the primary graphics card in a few tries to improve the situation. And then I did confirm that Rhino6 was using it by checking in options > view > opengl

I will upload the file using your link and refer there to this topic.

I mainly work in wireframe and shaded mode, but it has the problem in all view modes.

The reason I prefer to use the intel while working in Rhino, is that the when I render using the Titan X, and use that as the primary graphic card, the whole system becomes slow, whereas if I use the intel as primary, and render with the Titan X, the system stays usable.

Anyway, as said, this file is very slow with both graphic cards.

Hi @fjg85,

I’ve tested your file with an Intel 4600 and I can see the slowdown. However, for me Rhino 5 is just as slow. Opening the file and doing TestMaxSpeed gives me:

Rhino 6: Time to regen viewport 100 times = 12.14 seconds. (8.24 FPS)
Rhino 5: Time to regen viewport 100 times = 11.45 seconds

If I use my GTX 980 GPU TestMaxSpeed gives me ~2 seconds (~45FPS)

The scene contains 95 000 curves.

I’d be interested in hearing what you get when running TestMaxSpeed in V5 vs V6.


Good. The effect of slowing down is especially mainly strong when drawing / editing. Did you also have the slowdown there? That is where the file is really slow and unworkable in R6, while it works ok in R5…

Anyway, Here are my results with TestMaxSpeed:

Wireframe rhino 6 - intel4600: Time to regen viewport 100 times = 9.61 seconds. (10.41 FPS)
Wireframe rhino 5 - intel4600: Time to regen viewport 100 times = 3.64 seconds.

Wireframe rhino 6 - Titan X: Time to regen viewport 100 times = 2.31 seconds. (43.25 FPS)
Wireframe rhino 5 - Titan X: Time to regen viewport 100 times = 3.31 seconds.

Best, Friso

The slowdown is going to be much greater when drawing / editing / moving objects since it will draw all four viewports to reflect your changes in real time. When you rotate around in a viewport only that viewport is updated, and therefore it is faster.

What’s interesting here is that your Rhino 5 seems to be 3x faster than mine. Anyone else have ideas? @jeff @stevebaer?

David, can you debug on your 4600 gpu to make sure the gl33_curve shader is being used in V6? I would expect significantly different results from what you got.

I had a similar problem on my laptop that has an Intel 4000 chip. I fixed it by downloading from Intel the latest version of their video driver for that chip. The same thing might work for the 47000.

Please make sure you’re comparing apples-to-apples here…

Rhino V5 always turned OFF Vertical Sync, whereas V6 uses whatever the GPU setting is… You can control it in V6 using the scripted version of TestMaxSpeed…

For example:

-_TestMaxSpeed VerticalSync=Disabled ENTER

… It might not make a difference for some tests…However, it can make huge differences for others.


I have been running into the same issue. My biggest issues come into play when I load a High Res Mesh object. That’s where it starts, then if I have vertex snap turned on, moving my cursor anywhere close to the model causes a terrible hang. like go get a cup of coffee kind of hang.

Side note, if I turn on edges in rendered mode, it behaves like x-ray all wires is on. (I had this issue in Rhino 5 as well)

Huge meshes are slow in Rhino 6, yes. Are you saying that the same file wasn’t slow in Rhino 5?

Anyone updated the lastest patch and have freezing moments issues ?

I have had recurring freezing problems with Rhino 6 on both Windows and Mac computers and reverted back to Rhino 5 for a while. Then I started experimenting to try to isolate factors that might be causing the problem. For me the answer seems to be disconnecting any internet connection once the license has been retrieved for my Windows computers which share a cloud served commercial license. My MacBook has a stand-alone commercial license so I just disconnect from the internet before I start using Rhino. After I’m done I can get back online so my files synch up on Google drive. I did try moving the active file out of the Google drive folder while working to avoid incremental updates but as long as I had an open internet connection the freezes continued. I hope McNeel will get Rhino 6 more stable soon but at least I can use 6 now without the interruptions.

@abrahamwechter what Rhino 6 version are you currently using? (full first line of Rhino command _SystemInfo)

Windows- Just downloaded the latest SRC Rhino 6 SR14 2019-3-5 (Rhino 6, 6.14.19064.4371, Git hash:master @ d340745acdd
I have not had a chance to try it out yet but the previous SRC was tested and exhibited the freezes.

Earlier today I was on the MacBook running the 6 WIP (6.14.19057.13066, 2019-02-26)
This version exhibited freezing too and solved by disconnecting from internet.

I live in China and internet filtering may be a factor. However so far Rhino license retrieval has run pretty smoothly here even with no VPN.

Thanks, I just wanted the version info for the YouTrack item I’m about to create.


Thanks again for reporting.

Because you have a standalone license on your mac, I don’t think this is related to the licensing code. There’s absolutely no reason for a standalone license to even try to connect to the internet.

However, I wonder if this is related to the collection of usage statistics. On your Mac, please:

  1. Open Rhinoceros > Preferences
  2. Click the General page
  3. Clear the “Allow the collection of usage statistics” checkbox

Is Rhino able to run while you are still connected to the internet with this disabled?