R6 updates and R7 evaluation install will not start/install

I have been using R6 since the WIPs and everythign works great and it starts but ever time I’ve closed the file for the last couple months I get the “An update is ready to be installed” dialogue box. I click yes and literally nothin happns but the dialogue box closes. I have downloaded the update and when I click the .exe file it looks like it is going o run for a second then close and nothing. Rhino 6 is working great fro me at the moment so I didnt try to solve it very hard.

I just tried installing the R7 evaluation to test out some display settings and the same thing is happening.

I have installed tens of other programs since this has been a problem. I had to install sketchup yesterday to work with a file a client sent over. Anyone had this problem or any ideas?

My guess is I need to deinstall all of Rhino and start over, but that is scary as R6 s working and if I cant get it to install afterwards I am a little … screwed.

To be clear: There are no error codes because nothing happens.

Hello - please make sure all instances of Rhino are closed - look in Task Manager including the ‘Details’ page… it is not all that uncommon for there to be a ‘rogue’ Rhino that has not closed properly.

If you find some that are running but not showing normally on screen, right click and ‘End task’


I did that and now have followed the Manually Uninstalling Rhino Guide all the way down to editing the registry. I have restarted several times. I am a tad fearful of doing the “Cleaning the Window Installer Cache” and now I am at the point I fear. No Rhino at all. What in gods name am I doing wrong?!

I am trying install rhino_en-us_6.32.20340.21001.exe and/or rhino_en-us_7.1.20343.09491.exe. If I run them as Admin I get to the “do you want to allow this app to make changes to you computer” window. I click yes, and then boom. Nothing.

@pascal I noticed that when I try and run both installer and have Task Manager open that Rhino 6 and Rhino 7 both briefly show up and they are the 32 bit programs. is that the problem?

Hi Joseph - the 32 bit things you see are the installers. Both V6 and 7 are 64 bit. I tihnk I would look at getting possible Windows updates as the next thing to try.


giving that a shot

@pascal That was it. Thank you.

Why I could install other programs and not Rhino, I guess I’ll never know but its solved and I am happy!

1 Like