Rhino 6 installation problem

Hi @brian, i got this today when i tried to install RH6:


Here are the steps i got there:

  1. I had an unsaved script open in the Python editor
  2. Closed Rhino 6, it asked to install an update, i’ve clicked OK
  3. It started the installer, clicked OK to install
  4. At some point, it brought up above dialog
  5. I noticed that the closed Rhino is still active, asking to save the script
  6. I clicked No, so i did not want to save the script

Now if i clicked on Retry or Abort, nothing happened. It just hang there. After killing the installer, the installation is, of course, corrupt. Would it be possible that the installer recognizes this and does not start until Rhino6.exe is fully closed ?


Hi Clement,

When you say “After killing the installer, the installation is, of course, corrupt.” - what did you do to kill the installer? It shouldn’t be that having Rhino running would cause access rights to the System folder - instead, you’d normally just be asked to restart after installation.

Hi @brian, i’ve closed the executable from taskmanager.

Yes, and i have admin rights on the system and was logged in as admin.

I would have expected that when i click on retry or abort something happens. But this was not the case. I’ve given it 20 minutes, then i’ve closed it manually from taskman. When i tried to double click the link it creates on the desktop, i got a message that the link is pointing to an invalid adress.

So i searched on the HDD for the most recent installer, started it and installed it again.