Rhiexec.msi not found, instead rhino.msi in packages folder

unhandled

(Wolf Schweitzer) #1

Seeing as if so far I have no Rhino 6 installation that at all runs on my production laptop computer (prior posts), I run after every update version in the failing hope that then this update maybe corrects the errors of prior installations.

The latest one seems to go horribly wrong here. I get an error saying that a network (?!) resource cannot be found, the dialog specifically asks me to locate a package called rhiexec.msi; the latest package folder in the Program Data folder contains an exec called rhino.msi (not rhiexec.msi).

So at this stage I had a botched up messed up Rhino 6 installation that I removed entirely, then tried to re-install but total fail. The software concludes with:

Installation Failed with error code rhiexec.mis: -2147023293

Please let me know if there is anything that you really recommend to make Rhino 6 install correctly, and, run correctly.


(Wolf Schweitzer) #2

The problem with uninstalling that failed Rhino 6 and trying to install the previous version is that the uninstaller of Windows fails, too. The error with the prior installer is that it says there is a newer version installed even though the Control Panel > Programs lists nothing in terms of Rhino 6. How do I manually erase all traces of the botched Rhino 6 installation, is there a walk-through on how to perform that after the regular uninstall failed to remove Rhino 6? Thank you.


(Wolf Schweitzer) #3

I manually removed the Programs content folder of Rhino 6 and then the 22/5/2018 version installer would run again. That however also ran into the same error, not being able to find a network resource. So not even older installers work now. Crikey.


(Wolf Schweitzer) #4

Solved the installer problem following the manual registry deletion instructions here

https://wiki.mcneel.com/rhino/5/uninstall

This allowed me to finally install the software again.

Now, it still cold crashes upon start, as always, but at least it is the latest Rhino 6 version now, so no one can blame this not being up to date.


(Nathan 'jesterKing' Letwory) #5

Do you get the crash report dialog when Rhino crashes? If so, please make sure you submit the crash reports.

If you don’t get the crash report dialog please see if you have any files with “RhinoCrashDump” in them. Please zip them all into one archive and upload at rhino3d.com/upload . The crashdumps should find their way to a developer for further inspection.


#6

Does it also crash when you start rhino 6 in safe mode?


(Wolf Schweitzer) #7

Safe mode works fine.


(Wolf Schweitzer) #8

Thanks I will check / try that


#9

OK. then I suspect either a problem with your video driver or a problem with a plug-in that might have gotten transferred from your V5 install.

Couple of things you can try, first thing I would check is the video:

Start in safe mode, go to Options>Advanced and type 'hardware' in the search box, you should find the setting Rhino.Options.OpenGL.UseHardwareDriver, set that to False. Then exit Rhino and and try restarting normally (not safe mode). If it succeeds, then there is a video problem.

If not, then report back here, it might be a plug-in. Do you know of any non-standard plugins that might have been installed or gotten transferred from your V5 install?


(Wolf Schweitzer) #10

I had tried all that before. Rhino 6 generates the same freeze on startup with or without hardware acceleration enabled. The only plugin I have is the latest Boltgen ply plugin. The weird thing is that after one particular Windows update, Rhino 6 as it was suddenly ran perfectly well, and since the update thereafter, it never came back to life really. I did remove all 3D bloatware etc too. NVIDIA driver up to date.


(Nathan 'jesterKing' Letwory) #11

Can you check if the Windows update in question is KB4100403 as mentioned here:

If you have that installed, perhaps you could try rolling that back?


(Wolf Schweitzer) #12

The application does not generate a RhinoCrashDump. There is a Windows log entry though as Windows will ask whether the non responsive application should be closed.

Description
A problem caused this program to stop interacting with Windows.
Faulting Application Path: C:\Program Files\Rhino 6\System\Rhino.exe

Problem signature
Problem Event Name: AppHangB1
Application Name: Rhino.exe
Application Version: 6.5.18143.7081
Application Timestamp: 5b0583d9
Hang Signature: 0000
Hang Type: 134217988
OS Version: 10.0.16299.2.0.0.768.101
Locale ID: 1033
Additional Hang Signature 1: 00000000000000000000000000000000
Additional Hang Signature 2: 0000
Additional Hang Signature 3: 00000000000000000000000000000000
Additional Hang Signature 4: 222c
Additional Hang Signature 5: 222cc0f90b09500e4a1f236fede79235
Additional Hang Signature 6: 85b7
Additional Hang Signature 7: 85b7fda79a58966ec4fa6217ee814cdd


(Wolf Schweitzer) #13

Thank you for that suggestion. I cannot go back as the list of possible uninstalls does not contain that particular option here. I rolled my system back to a really prior version a few days ago then installed the updates again, cannot say whether that one has been installed. It certainly does not show up in my installation history.

However, I had the freeze on start way before that. The only thing new a few days ago was that the update installer failed too. Seeing as it if always froze on start (with a lucid window of a few days a while back who knows why) I guess it is just fate or bad luck. All other software that I use installs and runs, IDL runs, Meshlab, Blender, all doing fine. Problems only with this one.

Meantime, I also removed the Boltgen (Rhino 6 version) plug in that I had there as only third party plugin, removing that did not do anything either.

After the latest Rhino 6 update today, I noticed that as a new feature, Rhino now stops starting > with < a green little indicator going back and forth in the splash window at startup whereas before that updated it would gently freeze > without < that green thing going back and forth. First time ever I get an animated rather than still standing freeze, made me feel like I achieved at least a little thing. It still does not work but it looks better like that.

The problem with these Rhino 6 on startup freezes is that when I wait too long, until Windows eventually pops up the nonresponsive application shut it down dialog, I may get Blue Screens that take quite a while to recover. Whereas when I see Rhino 6 not starting and end the task via Task Manager before, I usually avoid Blue Screens. There are no Rhino error dump files or so. So waiting too long makes Rhino really crash the system bad.


(Nathan 'jesterKing' Letwory) #14

Hmm, that doesn’t sound good. Could you perhaps post the hardware configuration you are using, and for the GPU what driver version is installed.

From searching the internet I get mostly lots of crashes with this Windows version related to the GPU driver. Your Windows version is apparently Windows 10 version 1709 (Fall Creators Update). Most articles suggest updating both Windows 10 to the latest and doing the same for drivers.

Not sure what to suggest otherwise.