R6 UI colors aren't compatible/transferable to R7 BETA?

image

This is no longer exposed in R7

What controls this background color?

Found it, it’s this:
image

@brian Is there any other threads that discuss this topic? I searched but i cant find any that discuss the UI coding changes. It appears to me, at least for what i have set up and begun to poke around, that the OPTIONS > Appearance > Colors > General > “Window Color 2” color pick is being used for more surface area in the 7/Beta build than was utilized in R6. Can you confirm?

@Asterisk have you modified your Windows operating system colors? The “Edit Text” dialog does not match the colors that I see when I set my Rhino to a darker set of custom colors.

Our goal for V7 is to have the UI to that can be docked to the main Rhino window be more consistent with respect to the UiPaintColor settings in Rhino’s settings system. Floating dialogs will not be addressed until the future. This is why we are specifically not advertising any support for a “dark mode” in V7. We are getting closer, but still have a long way to go.

All of the colors are controlled by the UiPaintColor settings that can be found in the advanced settings page in Rhino’s options.

I have a list of additional custom colors that have been requested, but I haven’t done so yet.
https://mcneel.myjetbrains.com/youtrack/issue/RH-60648

Yes, I’m using High Contrast Grayed out theme.

It’ll suck to not be able to read these:
image

Background color for these are inaccessible from anywhere from what I gather? And the text color is controlled by Windows?

@Alain do you know if those controls are using the Operating System colors for background fill or are we just setting it to white?

Is there a doc that describes what all of these control? I can’t find UI elements for about third of them. Don’t see a UI change anywhere when I change them.

R7:

R6:
image

The Active Tab is no longer highlighted unlike R6.

Here’s the theme I’m using:
HighContrastGray.7z (722 Bytes)

[Theme]
; Windows - IDS_THEME_DISPLAYNAME_AERO
DisplayName=High Contrast Gray
ThemeId={30A4D7D0-E8D2-467C-BC88-C9A557F57D63}

[Control Panel\Desktop]
PicturePosition=4

[VisualStyles]
Path=%SystemRoot%\Resources\Themes\Aero\AeroLite.msstyles
ColorStyle=NormalColor
Size=NormalSize
AutoColorization=0
ColorizationColor=0X7F000000
VisualStyleVersion=10
HighContrast=3

[MasterThemeSelector]
MTSM=RJSPBS

[Control Panel\Colors]
ActiveBorder=45 45 45
ActiveTitle=45 45 45
AppWorkspace=45 45 45
Background=0 0 0
ButtonAlternateFace=200 200 200
ButtonDkShadow=15 15 15
ButtonFace=45 45 45
ButtonHilight=95 95 95
ButtonLight=35 35 35
ButtonShadow=75 75 75
ButtonText=250 250 250
GradientActiveTitle=195 195 195
GradientInactiveTitle=125 125 125
GrayText=125 125 125
Hilight=125 5 5
HilightText=255 255 255
HotTrackingColor=100 100 100
InactiveBorder=45 45 45
InactiveTitle=45 45 45
InactiveTitleText=200 200 200
InfoText=250 250 250
InfoWindow=45 45 45
Menu=45 45 45
MenuBar=75 75 75
MenuHilight=125 5 5
MenuText=250 250 250
Scrollbar=35 35 35
TitleText=250 250 250
Window=45 45 45
WindowFrame=15 15 15
WindowText=250 250 250

The tabs in general have all been restyled to draw a border only around the active tab.

Many of the “non-obvious” colors in that list are specific to mouse interaction with respect to toolbar buttons.

@stevebaer, by looking at the code, those custom controls (that JohnM made) wrap Eto controls and use different Eto.Drawing.SystemColors (maps to System.Windows.SystemColors on windows) for most states (Enabled, Disabled) and hard coded colors for other states (Red for invalid text)

Can you tell if the background fill is using a hard coded color?

The tab mouse over highlight is a nice touch in R7, but the active tab should keep the highlight color, so it’s clear at a glance what tab is active. R6 had it, now R7 only has a border outline that’s pronounced not nearly enough. Did people not like the active tab persistent highlight?

So I just imported back Appearance from Options.ini exported earlier to fix the colors I broke and it imported default colors essentially making me re-setup the UI colors.

Is UI colors export broken in R7? Why is it exporting UserName blank?
image

I’m not sure why it is exporting a UserName at all. I’ll make a bug for a developer to look at this. Are you using ExportOptions to make this ini file?

Yes. It also just reset all options to default when I re-imported all options for the second time.
Here is the Options file:
R7 Options.ini (103.7 KB)

I might know the issue - I was exporting options.ini to Google Drive folder and windows has issues writing stuff from other programs there or some such.

R6 has no issues in that regard though.

Thanks; I reported the bug at https://mcneel.myjetbrains.com/youtrack/issue/RH-61132

RH-61132 is fixed in the latest BETA

just imported my RH6 options into RH7 BETA…

Tab

tabs are not all under the same setting? (Rhino.Options.UiPaintColors.HotStart)

1 Like