R6 troubles - rendered view, properties options not showing

So my problems with R6 are: When I select some object, it´s not visibly selected in the rendered view - yellow contours. The second one is, when I select (usually more than one) text, dimension etc, there is missing options in the properties menu. Everything is very clear from the printscreens. This problem is just for R6, it did not happen in R5. When I click on “object properties” and than again on “text properties” it´s fine.

Hi Jan - is the Rendered mode at the default settings? Can you please run SystemInfo in Rhino and post the results?


Yeah, these kinds of REGULAR Speed-bumps which repeatedly FORCED me to step back to RH-5, as I really had NO TIME to hand-hold them through debugging THEIR PET SOLUTIONS.

Now it appears that OpenGL AA has been DISABLED in RH-5, (re: John Brock) forcing migration BACK forward to problems like THIS in RH-6 ? AND apparently RH-6 is affected THAT way, TOO ? I have relatively LITTLE interest in playing RHINO, and FAR MORE interest in selling my WORK PRODUCT to CLIENTS.

Good luck -


Hi Pascal,
when I restored the settings to default, the problem remains.
system info:
Rhino 6 SR14 2019-5-7 (Rhino 6, 6.14.19127.17141, Git hash:master @ 5b633aaa430941b76f5789a0ce3bb670ce06947a)
License type: Educational, build 2019-05-07
License details: Cloud Zoo. In use by: Jan ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-4C4U5MV

Hybrid graphics system.
Primary display: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 4-22-2016 (M-D-Y).
Primary OpenGL: AMD FirePro W5170M (AMD) Memory: 2GB, Driver date: 9-18-2018 (M-D-Y). OpenGL Ver: 4.5.14568 Compatibility Profile Context FireGL 24.20.12042.5

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.50
Driver Date: 9-18-2018
Driver Version: 24.20.12042.5
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Jan\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.4.17.851\SectionTools.rhp “SectionTools”

Hi Jan - can you save an example file in the state where selections do not highlight and post it here?


It has something to do with GPU I guess. Sometimes it works, sometimes not :frowning: When I saved and re-opened the file again it worked well (for both problems). Althought text properties looks corrupted and takes longer to load… I can still send some file, but I think you will not have the problem. Problem is for almost any file I worked with in last months…

Hi - this issue has been on our list for a while and looks to be fixed in an internal build. If so, that fix should be available in the next Service Release.

As for the selection highlighting - while not very old, it probably wouldn’t hurt to try and see if there are newer drivers for the FirePro W5170M.

If you find any pattern in the behavior, please let us know!

Hi, I´am glad to hear, that you are working on it. Althought it´s not very convinient to have these kind of bugs in a new non-beta version… Text and dimension properties still take very long to load and seems kinda buggy. Also you were probably right about the driver for the GPU. After an update it works fine, so thanks for reminding me.

So, the problem with highlighted edges in rendered mode sustains. Even after new GPU driver install…

Hi Jan - could you please post your updated SystemInfo along with a small 3dm file that shows this behavior? Thanks.