Procedure entry point issue won't let Rhino 4 run


#1

I was using Rhino 4. Left the computer for a bit to get some blueprints. When I returned. Rhino 4 was no longer running. Upon trying to start Rhino 4 again I discovered the Rhino.exe file and other files were GONE from my computer. I inserted the Rhino disk and choose the option of installing missing files. Now hen I try to start Rhino I get a pop up saying “The procedure entry point ?StayOnBoundary@@YA_NABVON_MeshTopology@@ABVON_MESH_POINT@@1@Z could not be located in the dynamic link library tl.dll”

I then removed Rhino completely from my system and reinstalled it. I still get the same pop up.

Running Windows XP SP3.

How do I get my Rhino up and running again?


(Pascal Golay) #2

@brian do you have an idea?

thanks, -Pascal


#3

Is your computer 100% under your control, or is it in a situation where someone could have been fooling with it or intentional sabotaging it?


(Willem Derks) #4

What I would do:

First: disconnect from internet,next I would create a full backup of all your crucial files a.s.a.p
Next run a full scan for viruses!

-Willem


#5

I live alone. Computer was not connected to the internet at the time of the problem.

Have ran multiple virus scans. No issues. Ran SFC. Did not resolve my problem.

Same error message when I try to start Rhino 4.


(Dale Fugier) #6

Try this:

1.) Uninstall Rhino 4.
2.) Make sure the Rhino 4 folder is either gone or empty (C:\Program Files\Rhinoceros 4.0).
3.) Reinstall Rhino from your CD
4.) If your CD is not Rhino 4.0 SR9, download and install SR9 from here:
5.) Run Rhino.
6.) If Rhino crashes, run Rhino in Safe Mode (Start -> Programs -> Rhino 4.0). When Rhino is up and running, run Tools -> Options -> Plug-ins and disable all plug-ins that did not ship with Rhino. Then Restart Rhino normally and begin to tur on 3rd party plug-ins one-by-one.


#7

Thanks dale

That worked, but there is a strange issue.

When Rhino starts up in the command line there is entered: “Select closed boundary curves for trimming:”

How do I clear the command line so this isn’t there every time I run Rhino?

Also all my custom menus are gone. Is there a way to get them back?


#8

This sounds like you have an entry in your startup scripts… As a matter of fact it sounds like one of my scripts (MultiBoundaryTrimCurves)… Check in Options>Rhinoscript to see if there is an entry in the box there. If so, if you remove it, it will not load at startup…

When you say “custom menus” do you mean toolbars?

–Mitch


#9

Yes toolbars. All fixed now. Thanks everyone.