Subd selection tools and vertex merge that I'd like to see implemented

yesterday I forced myself into using pure subd-modeling in Rhino, to see where the development of subd is at. What I think is very much needed are tools for selection:

Sub-object selection of points, edges, faces should be separated. Right now when I want to select a couple of edges, it is very difficult to do so, often picking the face of the edge instead or some face that is behind the edge I want to select.

Please add a way to select part of a ring or loop. Modo is a good example of how things could work: You select two edges of a ring, then you hit up and down keys to add or substract from the selection:

here you can also see that you can convert from points to edges to faces and vice versa.

Furthermore I found it cumbersome to stitch open edges. Please add a tool to stitch (merge) vertices within a certain tolerance. It could work like this:

1 Like

It was a good request

Agree 100%

The best solution I can come up with that fits with Rhino’s way of doing things is this:

  • next to the osnap panel at the bottom of the window, but separate from it, add a similar panel with five boxes: obj, face, edge, vert, disable.

  • create a ToggleSubDSelectionFilter command so those of us who don’t want to click boxes can toggle through the five options by tapping one key.



Agree 100%

Thanks for the feedback!..

This is in the latest WIP but you’ll need to run ToolbarReset to get the icons. You’ll have them in the Select SubD flyout but we are playing with location and they’ll move to be more obvious in the next WIP (ToolbarReset again to see the change after updating).

In general, if you sub select one edge and then the other end of the edge loop you want, you can double click on any edge in between to get the partial loop selection.

For the grow and shrink of sub selections, there’s an open internal request as RH-42371 that I added your vote to.

This is filed and I added your vote…

This is filed as I added your vote.


Thanks @BrianJ
Just why when we execute the command becomes unknown

1 Like

Filed as

1 Like

@BrianJ nice icons, but commands don’t work, checked for updates I have the latest

Weird, I have not seen that. Email your SystemInfo from the WIP to please and explain the issue. See if there’s any update and try restarting both Rhino WIP and Windows too just for good measure.

Okay, so that makes two times I’ve heard this :slight_smile: What’s your system info? A new WIP ought to go out today as well.

for time being I made this

let’s wait for that first then :slight_smile:

1 Like

Rhino 7 SR0 2020-2-18 (Public Build, 7.0.20049.13225, Git hash:master @ b8c41ee41de193a281d1b56fddd30f605dffb7f4)
License type: Commercial, build 2020-02-18
License details: Stand-Alone
Expires on: 2020-04-03

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: mehran

Hybrid graphics system.
Primary display: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 960M (NVidia) Memory: 4GB, Driver date: 10-22-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.08

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-22-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7 WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7 WIP\Plug-ins\Pangolin.rhp “Mesh2”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20049.13225
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Mehran 73\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\rhino-render-next\0.0.2\RhinoRenderNext.rhp “Rhino Render Next”

I installed the latest version :blush:


I need to learn to code!

@mehran09197306634me. @Gijs , @BrianJ, all - I think this is my fault - sorry!

Wait ! no, there’s a bug. It’s not my fault. Phew.



Hi @pascal I installed the latest update but it still doesn’t work

hi pascal it work for me !

Rhino 7 SR0 2020-2-25 (Public Build, 7.0.20056.13055,
Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19
OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

@pascal @mehran09197306634me @BrianJ

This is how to get the icons to work:

step 1 : export your aliases
step 2: reset aliases to default
step 3: re-import your aliases

Hi Gijs - yeah. thanks… Mikko made it so these are no longer aliases, too unreliable in the WIP. The next WIP will have these in there more solidly as commands.


1 Like