Problems loading Vray plugin for Rhino

Can anyone share light on this issue?

My Rhino 7 won’t load the VRay plugin. It just say’s “Error Loading - VRayForRhino.” Below is a screen shot of my issue.

I have had VRay previously loaded into This instance of Rhino 7. But a while back removed a bunch of plugins I wasn’t using, including VRay. I am now trying to use VRay again for a specific project.

I have tried reinstalling VRay a bunch of times. Each time VRay tells me it is uninstalling the previous version, before doing a fresh install. And then each time I open Rhino I get the same result. I’m not sure if there are maybe some files lingering in a folder somewhere that are causing this issue, or where they would be

If I have to reinstall rhino 7 for any reason, is there I can save all of my settings, plugins, etc, so they automatically load into the reinstall?

Problem solved. I followed this process in the image below (except I was searching for Vray instead of Land Design). Once I got to the VRay folder I just search “rhp” and loaded those files.