Problem - no sun on a reflective ball in vray

I have made a simple scene which includes a reflective ball, on which I expect to see the reflection of the sun. In rendered mode I can find it, but in V-ray Render window it is absent. Why can’t I see it in V-ray? Attached is the file try 2.3dm (721.4 KB)

Try to change the sun size to a bigger number, at least 5

Using the V-Ray sun is a three-step process. You missed the last two steps, which is very easy to do. [I think that V-Ray should automatically do steps 2 & 3 as soon as you place a Sun object.]

  • Place V-Ray Sun
    Go to V-Ray:Options → Environment roll-out.
  • Under GI/Skylight, turn on both ‘on’ and ‘map.’ Click the M for map and select ‘TexSky’ Select Sun = ‘Sun 1.’ OK to close.
  • Under background, turn on both ‘on’ and ‘map.’ Click the M for map and select ‘TexSky’ Select Sun = ‘Sun 1.’ OK to close.

Other tips:

  • Changed the sun size to 10 to get it to show up. You will get softer
  • The extra brightness will usually require you to adjust the exposure. Go to Camera to adjust.



V-Ray can be almost impossible to self-teach, especially if you are using the trial-and-error method.

The tip above came from a lynda course called Architectural Rendering with Rhino and V-Ray. Look for Chapter 03: Lighting and Exposure.

If you’re not a member, here’s a link for 10-days free. Good luck!

Thank you very much for your detailed explanation.
I am a member of Lynda and started to watch your V-ray course.
This is a GREAT course, the explanations are wonderful !! I enjoy it very much !!
Yet, in my file - I wanted to try see the sun only, without GI.
That is why I have unchecked GI and BG.
As far as I know - it is possible in Sketchup with V-ray.
Is it possible with Rhino and V-ray?
Why do I see the sun in Rendered mode, but do not see it in VFB window of Vray?
Thanks again

Thanks for the nice course feedback. More coming soon!

You may or may not be seeing the the sun in the viewport. I usually use the viewport with ‘default’ lighting because it’s brighter and better than having Rhino try to use the scene lighting. Rhino does not always use the plug-in data for many of the viewport festures you would assume they do.

You need to keep the skylight/GI on to see the sun. If you turn off the background, you’ll get less lighting, but then things like they are on the moon. Bright with black sky.

Also, go to the Global Switches where there some more controls for GI. I have actually never tried to use the sun without GI!

Thank you very much !!

How Should I set Rhino to “default” lighting?
As for V-ray - OK, I will use it as you recommend.

I have a suggestion for an additional video - The connection between Rhino and V-ray features,
for example - sun of V-ray and sun of Rhino, default lights of Rhino, Etc…
I found this subject to be kind of confusing for a new V-ray for Rhino user.

Thanks Rachel

Like most settings, you look under Tools→Options
Under Rendered→Lighting Scheme→Lighting Method, change to 'Default Lighting."
Make Ambient Color = 50% gray (RGB = 128,128,128) This will brighten things up a bit.

V-Ray can use the Rhino lights and sun. In fact, I think they might be identical as I have never noticed a difference.

There are more ‘introductory’ videos if you watch the course called Rendering Fundamentals. For the full list of courses I have done, go to the ‘lynda Dave Page.’ There are three courses on rendering with V-Ray and a fourth that covers rendering + animation.

Thank you very very much for your kind help !!!
You have been great help for me !!!