Printing pdf and lines aren't smooth

Hi everyone!

I am trying to make a pdf from my floor plan (which I made in Rhino with VisualARQ). The sample file here is simplified but the problem is same.

The problem is that when I print my floor plan into vector pdf, the result is not at all as smooth as in rhino layout view.

Here’s how it looks like in Rhino in layout view:

And after I print it with cutepdf it looks like this:

In Rhino all the lines and corners and round and smooth, but then in pdf you can see all these “not smooth corners” and gaps.

How can print pdf so that the result looks similar as it is in layout view? I used cutepdf in printing, but same problem seemed to be with RhinoPDF.

pdf_problem.3dm (2.7 MB) sample1.pdf (3.0 KB)

Rhino PDF should produce better results as it creates Beziers for curves in the PDF instead of polylines which is what you are seeing with your cute PDF output.

Here’s a capture from Rhino PDF print:

It is true that with rhinoPDF doors curved line is smooth but there is still problem with all the corners. You can see all these tiny notches in the corners (and in layout view there aren’t those).

How do I get rid of these “notches”?

Are you using Rhino 7? I thought I had fixed the end caps recently, but maybe my memory is failing me.

Yeah I’m using Rhino 7 (And VisualARQ 2).

So it seems that this can’t be fixed?

I’ve tried this with VisualARQ disabled, and the problem persists. So I hope McNeel developers (@stevebaer) can fix this.

1 Like

Hi -

The short answer is that you get rid of those by joining curves into closed curves:

line end caps - PDF.pdf (2.5 KB)
Top is closed, bottom is open.

To be able to change the end cap style (from square to round) is something that is on the list but until that is implemented, you’d want to deal with closed curves. And perhaps that’s where VA could do something?

This will be fixed in Rhino 7.5

1 Like