Printing to PDF

Hi there - I am having some confusion when it comes to printing to pdf, as I’m relatively inexperienced at the whole layouts side of things.

17_RPDF.pdf (70.8 KB)

In the attached pdf, it seems that the curves and circles etc. in the details (the floor plans parts) are segmented depending on the DPI of the print (using RhinoPDF in this case). I thought this was just a limitation of the software, yet when I draw the same curves in the actual layout itself (see bottom left hand side), they print perfectly without segmentation.

It appears as though the content of the details is subject to the segmenting. The doors blocks are VisualArq elements, but I also have native Rhino blocks and curves in there and all are printing in the same way. My question is is it possible to attain the better quality of print in the details as well?


Hi Ben - can you please post a 3dm file with just a couple of the things that do not print as you expect?


Hi Ben

I had a similar problem.
Please refer to my question.

I couldn’t solve this problem either.


Thanks Pascal - I have attached a simpler 3dm file along with the PDF I produced using RhinoPDF. Sorry if my previous message wasn’t clear.

As you can see the curves which are drawn directly in the layout space are perfect, whilst the curves which are drawn in model space but visible in the frame look to be segmented straight lines when you zoom in.

Thanks Pascal and hope you can help me with this.

PS. Jaesung, thank you - you appear to have the same issue. I don’t know if this is a bug or just the way Rhino works!

Rhino PDF Curves Test.3dm (7.5 MB) BIM_VisARQ_01.pdf (566.5 KB)

Hi Ben -

When I put that detail into the Wireframe display mode, the curves come out smooth - see attached PDF. The Hidden display mode that you used is provided by the VisualARQ plug-in. I’m changing the category on this thread but I’m not sure if there’s anything that can be done about this issue.

BIM_VisARQ_01-wrmd-Wireframe.pdf (46.1 KB)

Hi @Ben_B,

This is completely normal on “Hidden” display mode. “Hidden” display mode is a special display mode provided by VisualARQ, similar to the “Technical” display mode that comes with Rhino. This display mode shows in realtime only visible edges and silhouettes of solid objects.

Additionally, this display mode supports printing in vector mode in real-time, with silhouettes and hidden lines occluded, something that “Technical” display mode does not support. “Wireframe” display mode can be printed in vector mode, but this mode does not hide occluded edges, and it also doesn’t show silhouettes.

In order to achieve this feature, VisualARQ uses the meshes to compute the silhouettes. Using higher quality meshes will improve solids silhouettes. Curves need to be faceted because VisualARQ needs to check which parts of the curve may be occluded by other objects, and this algorithm can only work on straight lines, so curved curves must be tesselated. They are faceted according to the requested DPI, so the curves should be visually identical at eye-sight if you print the layout to a real paper.

Curves in the layout cannot be occluded by any other object, so they are just printed normally without being facetted.

Maybe circles in your PDF circles are too faceted. Can you send me the original 3DM and which settings are you using when printing so I can take a look?



Hi Enric I understand now, thanks for clarifying.

My circles aren’t too faceted -the straight segments are only visible when zooming in beyond 100%, so prints would look totally fine I’m sure It was just the perfectionist in me that was wondering about this discrepancy. But these days we do more often look at pdfs digitally than printed, and often zoom in so in an ideal world these curves would be perfect.

Thank you,


Hi Ben,

We’ve plans to improve this feature. One easy fix will be to draw the original curve if no part has been occluded, or try to detect the params from the original curve where an occluded segment start, then split the original curve on these params, and draw the splitted curve, which will look perfect. This will slow down the printing a little, but I guess many users will prefer a more detailed output at the cost of waiting one more second.



1 Like

Yes, exactly that sounds like a good idea. You could even maybe include the option to do it one way or the other, depending on whether quality or speed of printing is the priority.

FYI in my opinion the hidden mode is great, it’s one of the best things about VisualArq - you’ve basically made a live make2d. One would think that would have been implemented in native Rhino, as I imagine it would benefit many users.

1 Like