Print failure - missing and blank

OK, I could really use some help here, as I missed deadlines with printing failures.

I am trying to print PDFs from Layout space. I have typically one detail view in a layout page.

The view looks correct on-screen when I have Print Detail turned on to show the lineweights and print color.

Printing in either vector or raster is leaving large blank or masked out portions of the page. Sometimes this is constrained to within the detail view (this seems like the vector-outputs). Sometimes the blank or masked out areas are both within the detail and over the objects and text in the layout space (title block, etc). This seems like the raster-outputs.

I have tried these things, and all have failed to fix the printing errors:


-RefreshShade. (This has seemed to work in the past).


-ClearDrawOrder (Even though this will cause problems with the final print in hiding certain lines and hatches beneath objects).

-Changing the print color of the layer that contains the actual detail rectangles from white to a visible color. I usually have the layer color on white so that it “disappears” when PrintDisplay is on, for visual acuity.

-Going into the detail, changing to wireframe mode, RefreshShade, ClearAllMeshes, then returning to the custom shaded mode, then getting out of the detail back into layout space.

-Going into model space, saving the current layer state, turning on all layers, RefreshShade, ClearAllMeshes, then turning back on the current layer state.

-Printing with PrintDisplay off.

-Saving a detail’s layer state, creating a new detail, restoring the layer state into that new detail, trying to print that detail.

-Turning on all layers everywhere, then printing, even though the detail shows a bunch of garbage. Still, objects within the viewport are missing their outlines, or are outlined in white.

-Going into model space, deleting (almost) all the objects on unused layers.

-Going into the detail view, grabbing everything visible in that detail’s “model” space, moving it 1,000 ft away. Then go into true model space, delete all objects left remaining in the original spot, then moving back the selected objects into place, then returning to layout (this will leave the objects originally visible in the detail, still there).

-Updating my PDF printer from Adobe Acrobat 9 Professional to Adobe Acrobat XI Standard.

-Close Rhino, reboot the computer.

The odd thing is that certain layouts print fine (A1.3, A1.4) while others fail every time.

Would someone please figure out how to fix this?

File uploaded to at

Thank you!
Matt Flynn

Hi Matt- I’ll take a look, but I would also try more than one pdf driver - they seem not to work the same.


are all candidates that are worth a try, no doubt there are others.


You may also want to disable any 3rd party plug-ins installed in the PlugInManager and then restart Rhino. This will eliminate the potential of a plug-in being the cause of the bug.

Thanks Steve,
Plug-ins disabled. That did actually stop one non-associated dialog box I had, but did not affect the printing issue.

Hi Pascal,

Thank you for the links; I am hesitant to try them though, since most of them either have adware built in (Cute & Primo) or reviewers have warned that they got malware by installing them (Bullzip). Plus, I am using the “true” PDF maker, Adobe Acrobat. If Rhino was going to print properly with any PDF maker, wouldn’t it be with the default PDF standard?

I tried other approaches, which also somewhat failed:
Since the detail of the plan view on A1.4 prints properly, I copied this to one of the non-properly printing layouts (A1.1 and A1.2), deleted their details, and pasted the properly-working detail from A1.4. Then I changed that detail’s layer state. This printed properly! However, copying that detail to a layout that had a detail of a different view or a different scale did NOT print properly.

Also tried updating my Nvidia driver. That also did not solve the printing issue.

Thoughts? Thank you.

Hi Matt - I don’t know for sure that it will help, but another pdf driver is worth a try - as I understand it, Acrobat has been much more problematic for us than some of the other drivers. I have no idea about the possibility of malware - I’ve used all but bullzip and they all seem OK here… I think @John_Brock uses bullzip and likes it alright.


Hi guys,

I’m having very similar problems to the OP. However, my problems occur prior to trying to print. Some of my details display as expected in layouts (plan/top views in particular seem to have no problems). However, other views (particularly side views (left, right, front, back) have problems displaying.

The specific issue is that details showing section views (e.g. left or front views) show objects with the wrong colour, and some objects are not displayed at all. I suspect it is something to do with clipping planes, as the views where I am having problems have clipping planes associated with them.

Below are some screenshots to illustrate the problem. I’ll also upload the 3dm file.

The images show the following:

  1. My layout with all content displayed (wireframe mode). All the objects showing in black should either be red, turquoise or grey.

  2. My layout after entering model space within each detail, and exiting back to paper space. Many entities are now not shown.

  3. The entities can be forced to display correctly again bby going to the menu at the top left of the layout window, and running the mouse up and down over the detail names.

  4. Printing: the layout shows all the entities (although not in the correct colours), but the print preview does not.

I suspect this is related to the issue the OP has.

I’m using a laptop (Toshiba Satellite) with integrated graphics (Intel HD graphics 4600) with windows 8.1 (64-bit) and Rhino 5 64bit. I’ve tried many of the suggestions made by the OP, but without resolving the issue. I’ve also tried:
-using 32-bit Rhino.
-disabling OpenGL
-changing various graphics settings
-copying and pasting the model into an empty Rhino file and recreating the views there.

If anyone can figure out what is going on here, it would be much appreciated!

Many thanks,

Have you guys tried printing with the SR11 release candidate?

Does this behave better if you ExplodeBlock and then print?


I exploded all my blocks but that doesn’t change the situation for me.
I haven;t tried RC11 yet. I’m using the trial version of Rhino 5 (until I can convince my new company to buy Rhino - used it for years at my last job :smile:)

More tries and failures:

-Printed out of Bullzip. Same issues with missing or blanked screen portions occurred.

-Tried resetting the detail layer on/off state.

-Tried deleting all the geometry that is unused or on frozen layers. Now all layers in model space are on except one layer with only hidden clipping planes.

-Using viewcapture. While the saved bitmap does display correctly, at a scale resolution of 1, the image is simply not big enough for use. I am printing blueprints at a 24"x36" size. Even getting a bigger screen isn’t an option, as I’m using a 30" display.

-Using -viewcapture and setting the scale to 2 or more. This does not work for two reasons: 1) in layout mode, -viewcapture, when scaled up, does not actually grab the full screen. Somehow it limits or crops its output bitmap to a smaller areaand forces the view down into one corner (usually the lower left). 2) -viewcapture with a scale setting other than 1 reduces the lineweights (set by layer) and so all the lines turn out really thin. This just won’t print and be legible as architectural documents.

It seems like the issue is somehow related to this zooming-disappearing-object issue:

I am thinking this because when I zoom in in a layout, at certain points some objects pop in and out of visibility. Yet not necessarily the entire object (sometimes yes, sometimes no), but it seems like the prints are following the visibility popping. Does Rhino, when it prints, turn on PrintDisplay, zoom in internally, and do a viewcapture at a certain resolution to create the print? If so, then is that acting funky and causing these print failures?

I am using Rhino 5x64 SR10 on Windows 7x64. I have one computer running an Nvidia Quadro 4000, and a second computer running an older Nvidia Quadro FX5600. The Quadro 4000 had both a recent driver, and not the latest. No change to the printing issue. The Quadro FX5600 has a very recent driver 340.66.

Please help!

Hi Steve,

SR11 candidate seems to work. It at least allowed me to print a 99% correct PDF. It seems to have stopped the zooming-disappearing-object issue for nearly everything, although I did notice one glitch which also appeared in the 1% PDF print error. This was when three boxes were stacked left-to-right, viewed from the top downwards (so you see four edges left-to-right). When zooming in, and on the printed PDF, Rhino’s display made the two interior shared edges of the three boxes disappear. So when printed, the three boxes appeared as one large box (without any internal separation), which is still a glitch. On that same file I uploaded to tech@mcneel, this would be the main triple beams, in blue, seen on sheet A1.5.

I used Adobe Acrobat XI to print.

I tried Bullzip PDF to print, and again the same internal lines on those triple boxes failed to show up, although the other 99% printed correctly.

Thank you for suggesting SR11 candidate. At least it will allow me to get this project out!

Hi all,
I also use Rhino 5 for architectural drafting and I never Experience such issues with pdf printing.
Maybe sound stupid but are you sure that all the curves are flatten to the cplane? Zone missing may be related to clipping planes of the view?
Also try pdfcreator from sourceforge I use it and got good pdf.