PDF Printing Troubles

I’m not sure if this is a bug, a limitation, or if the problem lies somewhere between the chair and the keyboard…

PDF printing is not working properly (or at least as it did in v5) for me. In my title block I use a .bmp picture object along with regular text objects and curves making up the remainder. The detail views are in shaded mode and all of my dimensions and other annotations etc. are created in paper space. When printing to PDF using either the rhino or adobe PDF printer it will only print what’s in the detail views and not anything that is created in paper space despite the print preview showing everything there. If I remove the picture object it prints everything okay, but unfortunately, not having a company logo on a drawing is not an option. Likewise, if I print the title block without any detail views it prints fine.

I tried recreating the logo as surfaces in paper space but I get black outlines around everything making it illegible. The only way I was able to get it to work was to have the logo created as surfaces in model space through a detail that is shown in rendered mode. Not really okay for me to have it living in the model space under normal circumstances, I was just too far into the layouts on this one to go back to v5.

Could this be a raster/vector issue? I tried both options in the print properties and neither worked.

Could it have anything to do with the source image file format? I tried .jpg and .bmp because I happened to have both handy. Is there a recommendation?

Is there another means that I’m not aware of by which I can achieve this in paper space?

I’m using the evaluation version (6.2.18051.9541, 2/20/2018)

Any help is greatly appreciated!

I’m not sure what the problem is. Any chance you can share a sample so I can try to repeat the problem? If the file shouldn’t be shared, you can send it directly to me (steve@mcneel.com).

Currently, if you have an image in layout space, layout space objects will not print.

That is exactly it, and a much more concise way to put it. I hope this is something that can be fixed.

Print Test.3dm (1.4 MB)

It is pretty easy to duplicate, but here is an example:

NoLayoutPrintExample.3dm (516.9 KB)

NoLayoutPrintResult.pdf (2.8 MB)

I’ve figured out a workaround of sorts. If you print as .jpg it works properly so you can then combine the files in acrobat and get a .pdf that way.

Also, for what it’s worth, in messing with it a little bit more I found that it will print straight to pdf correctly if the details are in wireframe but the shaded modes are a no go.

I’m not able to repeat this, but I’m also on the latest build of Rhino. Hopefully the release tomorrow will fix this issue.

With the latest service release, over here everything now prints except the layout space image. So better, but still not working correctly.

Also, I noticed an unrelated printing bug in this SR RC, if I have a bit of text with no font associated with it, Rhino will fail to print to native PDF.

NoPrint.3dm (73.8 KB)

I’m not sure how this bit of text came into being, but if you select it the text has no font assigned to it. The file that this came from as been passed back and forth in our office, so perhaps it had a font assigned that I don’t have on my machine? Previous versions didn’t seem to care, but with the latest service release, it yields an error reading “Unable to read beyond the end of the stream” and no PDF is created.

On the more papercut end of this bug, if the print fails, PrintDisplay seems to get switched on, and I have to toggle PrintDisplay on then off again to clear it.


Hi, I’m on release (6.2.18065.11031)

I’ve been able to have either:

  • details with shaded / rendered display. OR
  • images in my layout spaces, and the print works fine…

If I have both of the above in one print, then the PDF fails and comes out with errors…

Heres some examples:

test-no image.pdf (74.7 KB)
test-wireframe.pdf (85.1 KB)
test-both.pdf (157.6 KB)
test.3dm (1.8 MB)

Also, when i have a rendered detail, the images in layout get shaded darker for some reason.



I can repeat the dark image bug: https://mcneel.myjetbrains.com/youtrack/issue/RH-44685.

Can you post a screen shot of your Print settings to reproduce the erroneous PDFs?


Just making sure someone saw this, or if perhaps if it needs its own thread. Our office is having serious problems printing out of V6 due to this. Trying selText or selLeader and changing fonts is also often causing V6 to crash.


1 Like

Thanks Sam; I’ll look at this today

Hey @SamPage ,
I’m testing with the build of the minute and am getting the DF_02 to print in the lower right corner of my PDF. Is that what was not working on your computer? I can install older builds to check on this, but want to make sure I am looking at the right thing before going down that path.

If you select DF_02, and in properties there is no font, and DF_02 it prints and you see no error, then it would seem that it is working and I don’t think you need to try on older builds. We also have seen that when using the font UbuntuCondensed-Regular, the printing fails even when that font is installed on the machine trying to print. If you need that I could send it to you.


Probably best to send me that font as I don’t have it installed. I select DF_02 and the properties pane shows Arial. That may be because I don’t have your font and Rhino is just defaulting to the most default font of all time.


Thanks for taking a look.


There’s definitely something funky going on with that font. I contacted the company that writes the PDF toolkit we use about this and will come up with some sort of work around for when situations like this happen.

I just put in a fix so at least Rhino falls back to Arial when it fails to use this font. This will be in the next SR3 release candidate. Will still investigate why this particular font is acting up.

Here’s a screengrab of the print settings. It happens on both vector and raster setups.


Thanks, I can reproduce it now: https://mcneel.myjetbrains.com/youtrack/issue/RH-44742.