Possible bug? post effects in the rendered image screen process only for a few seconds

Bug occurs on my Windows 10 I7 surface studio running Rhino 6 SR27 2020-6-24 Rhino 6, 6.27.20176.05001

I tend to make quick and dirty renders of my model files with dimension annotations to use with my assembly instructions and today i noted a bug. I typically use the “annotations” and “isocurves” options (adds a more tech drawing look to the render and makes certain details more defined)

So when you hit render you can not access the post effects screen till after the render completes. once complete you can select the tab and check a box, and if you are really quick a second box… once the first check box finishes rendering, the check boxes no longer have any effect on the image and i have to cancel the render and start over. there seems to be no refresh or other way to get it to process again. because of this behavior i had to try three times to check the box fast enough to get my finished picture. Is this a bug or am i missing something?

I was able to repeat that bug.

1 Like

thanks for confirming … oddly this is a workflow i do rather often as i 3D print models for the hobby industry that must be assembled and use cut dowels to assemble that need to be measured. This has worked fine in the past. The render post effects have been known to lock up the render, but this bug behavior is new

I have not yet tried it in V7.
The V6 Rhino Render is replaced by the Cycles engine for V7.
My expectations are for much better realism and faster.
I’ll try it later.

This problem has been fixed and tested and will be in the V6 SR29 SRC probably late July and in the released Service Release a month later.

RH-59485 is fixed in the latest Service Release Candidate

1 Like