Polyline stuck ish, on cplane


Hello! I am having trouble with my poly lines snapping to the cplane in perspective view, even though I have turned off “project” and “planar”. If I make a 3d object, I am able to draw poly lines snapped to that, but that’s it…

Are you having problems when drawing a polyline?

Turn Planar on and Project off to draw a polyline at a constant z value (height above or below the Cplane). An osnap will override Planar. Rhinoceros Help

The Planar command limits successive picked locations to the same construction plane elevation as the previous location.

Planar mode aids in creating planar objects with commands that allow free picking. Successive points have the same construction plane elevation.

Thanks for replying! Yes I am having problems when drawing a polyline.


It’s like it just wants to stay on cplane, but I can snap to object above cplane. It must be something I have clicked or turned on/off, since earlier today it was completely fine. Now it just wants to work on one plane.

I can se that my cursor vanished in that photo^, but the cursor is above the last anchor point on the polyline(which means it is still on cplane, and not above).

That is consistent with ProjectOsnap being turned on, although from your screen capture it appears to be off. Rhinoceros Help

ProjectOsnap

Toolbar Menu

Object Snap|Tools

Object Snap >

Project to Plane|

The ProjectOsnap command projects object snaps from the actual snap point to the construction plane.

Steps

  • Specify a command line option.
    When Osnap projection is on, and the cursor is over an object snap point, the marker projects to the current construction plane with a white tracking line between it and the cursor.
    If Planar mode is on, the ProjectOsnap command will project the object snap to the “virtual plane” that is set by the planar mode.
    When projection is on, the prefix “Projected” is added to the tooltip as a reminder.

Command-line options
Enable Object snaps will be projected to the construction plane.
Disable Object snaps land on the object snapped to.
Toggle

Yeah ProjectOsnap is off, that’s what’s weird about it:/

Do you have Planar on? That behavior is consistent with Planar being off even when the ProjectOsnap is also off.

Planar can be toggled using the P key. I’ve accidentally toggled it off or on numerous times.

https://docs.mcneel.com/rhino/7mac/help/en-us/index.htm#commands/planar.htm

Planar

Toolbar Menu Alias Application Toolbar

Not on toolbars.|

Not on menus.|P|Planar|

The Planar command limits successive picked locations to the same construction plane elevation as the previous location.

Planar mode aids in creating planar objects with commands that allow free picking. Successive points have the same construction plane elevation.

Example

  1. From the Curve menu, click Free-form, then click Control Points.
  2. Pick the first point in the lower part of the Top viewport.
  3. Move the cursor to the Front viewport and continue drawing.
    You will see that all the points you pick define a planar curve at the same elevation in the Front viewport. (Watch the Top and Right viewports). That elevation for the Front viewport was defined by the very first point you placed in the Top viewport.
    With Planar off, the subsequent points would be at elevation 0 in the Front viewport.

Note

  • Each point picked in a viewport will have the same elevation from that viewport’s construction plane as the previous point, regardless of where the previous point was picked.
  • Planar mode can be overridden with elevator mode or object snaps.

SetPlanar

Toolbar Menu

Not on toolbars.|

Not on menus.|

The SetPlanar command turns Planar mode on, off, or toggles the current state.

Steps

Command-line options
On Turns planar mode on.
Off Turns planar mode off.
Toggle Toggles planar mode.

I´ve tried both with and without Planar on. It´s when I’m in perspective view that the “bug” happens. It’s like I´m stuck to cplane (I´ve also tried changing the cplane, and the Polyline still follows that), unless there is a point to snap to(or by using elevation), and not in free form.

Note that any clicked point will automatically fall on the CPlane if it is not snapped to something that is not on the CPlane. That’s just how it works - that is what a CPlane is for - to have a plane for constructions to go to.

1 Like