Planar Mode not working


#1

I cannot for the life of me get Planar Mode working in Rhino Mac 5.2. What else do I need to turn on/off to get planar mode to work? Currently when I draw a polyline in top view with Planar mode on it snaps to whatever Z position it finds points on.


#2

Don’t know about “planar mode”, but if you set the Cplane to it’s default position “World Top”, and enable ProjectOsnap, all points you place will be set to z=0.


(John Brock) #3

It sounds like you have “Project” selected in the Osnap panel.
Try unselecting it. Then your selected points and Planar Mode points won’t be Projected to the CPlane.


#4

I have the same problem.


#5

Many people do not understand how Planar mode works and how it works together with Project. Here are some guidelines:

First, object snaps normally take precedence over Planar mode. So you cannot expect Planar mode to keep everything on the same plane if you use object snaps - except under the following conditions:

With Project off and Planar on, snapping the first point of a curve or surface creation tool to an object will set the planar “height” relative to the active CPlane. Any succeeding mouse pick points will stay in the same plane - assuming they are created in the same viewport and not snapped to anything else.

If you need to have the succeeding object snaps projected to the same plane as the first point - what many people assume Planar does by itself, but does not - you need to activate Project after the first snapped point. This is how Planar and Project work together to create planar curves and still use object snaps.

If you activate Project before snapping to anything, everything will be projected to the active CPlane.

–Mitch


#6

Heys guys,

I have this same issue, on Rhino 4 I had this issue but when I unchecked Project it got fixed. On Rhino 5, with Project unchecked it still does not work. I don’t need succeeding snaps or anything, I am just trying to move an object on one of the views without it changing having it snap in the other direction.

Thanks


(Pascal Golay) #7

Hi Gonzalo - did you read Helvetosaur’s post above on how Planar works with Project? Is it still not working, with that in mind?

-Pascal