Picture frame pictures cannot be found


#1

Background- I have a Rhino file in which I imported product definition for a turbine part. The part has run in an engine and has distress. I took pictures of the part and pictureframed them in this file. My intent is to trace over the distress in the pictures and project these locations onto the airfoil shape.
Two questions: 1- can you draw on a pictureframed picture, when I try to place polylines on the distressed areas of the picturee they are projected to the x-y plane and are not on the surface of the picture as I desire. 2- After saving the file, closing and reopening the pictureframe pictures carry a notation that the pictures cannot be found although text on the frame show the correct path to the picture. The pictures are located in a folder on my desktop. Why can’t they be displayed?


(Pascal Golay) #2

Hi msBob

All input goes to the CPlane as a rule unless it is overridden somehow, as by an OSnap. You can either use PersistentOnSrf osnap, or set the CPlane to your picture frame surface (CPlane command > Object)

That certainly seems wrong - are the images on the local hard drive? Where is the Rhino file saved? Note that when creating the pictureframe, you can choose to embed the image in the Rhino file, which should help, but it would be good to figure out why it is not seeing your images.

-Pascal


#3

Pascal,
The images are on the local hard drive along with Rhino and the Rhino output files. I thought that this behavior was strange and reinserted the photos and the same thing happened. Once the file was saved and restarted it had lost the image.


(David Cockey) #4

Just a guess but move the photos to a folder in a different location rather than the desktop. Then try again.

My reasoning: there may be a shortcut on the desktop to the current folder rather than the actual folder.


(Pascal Golay) #5

Hi msbob- something of a shot in the dark, but please try:
Close all Rhinos
Right-click on the Rhino icon and choose ‘Run as administrator’.
Add Pictureframes (without the embed option for this test)
Save, close and reopen Rhino… anything there?
If that worked, please repeat, starting Rhino normally, not running as admin - is it still working?

-Pascal


#6

So far the problem is fixed. I started embedding the pictures and so far they are staying. I did notice that previously the pictures that got lost were ones that I had rescaled. The non-embedded pictures that were not rescaled were still visible in the file.

Right now I am happy because I am able to perform the desired actions with the result that I was looking for.

Thanks for your help.


#7

Hi Pascal,

I tried what you suggested and cannot replicate the issue. In both cases the picture was displayed in the file.

As my previous note stated I have achieved what I wanted so I am happy.